summaryrefslogtreecommitdiff
path: root/script/Jenkinsfile.fossa
diff options
context:
space:
mode:
Diffstat (limited to 'script/Jenkinsfile.fossa')
-rw-r--r--script/Jenkinsfile.fossa20
1 files changed, 20 insertions, 0 deletions
diff --git a/script/Jenkinsfile.fossa b/script/Jenkinsfile.fossa
new file mode 100644
index 00000000..480e98ef
--- /dev/null
+++ b/script/Jenkinsfile.fossa
@@ -0,0 +1,20 @@
+pipeline {
+ agent any
+ stages {
+ stage("License Scan") {
+ agent {
+ label 'ubuntu-1604-aufs-edge'
+ }
+
+ steps {
+ withCredentials([
+ string(credentialsId: 'fossa-api-key', variable: 'FOSSA_API_KEY')
+ ]) {
+ checkout scm
+ sh "FOSSA_API_KEY='${FOSSA_API_KEY}' BRANCH_NAME='${env.BRANCH_NAME}' make -f script/fossa.mk fossa-analyze"
+ sh "FOSSA_API_KEY='${FOSSA_API_KEY}' make -f script/fossa.mk fossa-test"
+ }
+ }
+ }
+ }
+}