summaryrefslogtreecommitdiff
path: root/share
diff options
context:
space:
mode:
authorRuss Allbery <rra@cpan.org>2016-10-27 23:10:38 -0700
committerRuss Allbery <rra@cpan.org>2016-10-27 23:10:38 -0700
commit13de300b4e7a44201e6d6b23332c89b66d68c82d (patch)
tree759f688e4fec5ffd85228edf3148ab239e2ab326 /share
parent101c5618559b262686f03d1ba9ef26cc362f8082 (diff)
Add stock building and installation section for Perl
Add support for stock building and installation sections for Perl module packages using either Module::Build or ExtUtils::MakeMaker.
Diffstat (limited to 'share')
-rw-r--r--share/templates/readme-md.tmpl30
-rw-r--r--share/templates/readme.tmpl26
2 files changed, 56 insertions, 0 deletions
diff --git a/share/templates/readme-md.tmpl b/share/templates/readme-md.tmpl
index 6639512..c2e3685 100644
--- a/share/templates/readme-md.tmpl
+++ b/share/templates/readme-md.tmpl
@@ -31,6 +31,36 @@ configure.ac or any of the m4 files it includes and need to regenerate
configure or config.h.in, you will need Autoconf [% build.autoconf %] or
later.[% IF build.manpages %] Perl is also required to generate manual
pages from a fresh Git checkout.[% END %]
+[% END %][% IF build.type == 'Module::Build' %]
+## Building and Installation
+
+[% name %] uses Module::Build and can be installed using the same process
+as any other Module::Build module:
+
+```
+ perl Build.PL
+ ./Build
+ ./Build test
+ ./Build install
+```
+
+You will have to run the last command as root unless you're installing
+into a local Perl module tree in your home directory.
+[% ELSIF build.type == 'ExtUtils::MakeMaker' %]
+## Building and Installation
+
+[% name %] uses ExtUtils::MakeMaker and can be installed using the same
+process as any other ExtUtils::MakeMaker module:
+
+```
+ perl Makefile.PL
+ make
+ make test
+ make install
+```
+
+You'll probably need to do the last as root unless you're installing
+into a local Perl module tree in your home directory.
[% END %]
[% FOREACH section IN readme.sections %]## [% section.title %]
diff --git a/share/templates/readme.tmpl b/share/templates/readme.tmpl
index 3f4bf6a..ccb5109 100644
--- a/share/templates/readme.tmpl
+++ b/share/templates/readme.tmpl
@@ -34,6 +34,32 @@ REQUIREMENTS
configure or config.h.in, you will need Autoconf [% build.autoconf %] or
later.[% IF build.manpages %] Perl is also required to generate manual
pages from a fresh Git checkout.[% END %]
+[% END %][% IF build.type == 'Module::Build' %]
+BUILDING AND INSTALLATION
+
+ [% name %] uses Module::Build and can be installed using the same process
+ as any other Module::Build module:
+
+ perl Build.PL
+ ./Build
+ ./Build test
+ ./Build install
+
+ You will have to run the last command as root unless you're installing
+ into a local Perl module tree in your home directory.
+[% ELSIF build.type == 'ExtUtils::MakeMaker' %]
+BUILDING AND INSTALLATION
+
+ [% name %] uses ExtUtils::MakeMaker and can be installed using the same
+ process as any other ExtUtils::MakeMaker module:
+
+ perl Makefile.PL
+ make
+ make test
+ make install
+
+ You'll probably need to do the last as root unless you're installing
+ into a local Perl module tree in your home directory.
[% END %]
[% FOREACH section IN readme.sections %][% section.title FILTER upper %]