summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDmitry Bogatov <KAction@debian.org>2018-12-02 05:36:55 +0000
committerDmitry Bogatov <KAction@debian.org>2018-12-02 05:36:55 +0000
commit11470c63662bffe68b6b5fbfccdf5f34d208bcb6 (patch)
tree09132849fdfd36f35fdb1d2f57c6ef44a2d02b22 /setup.py
parentd621b3047b2b9dd96c952b8e0c420368796672eb (diff)
Import Upstream version 6.5
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 25 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index e6cdbe7..939528b 100644
--- a/setup.py
+++ b/setup.py
@@ -3,11 +3,33 @@
from distutils.core import setup
setup(name="dtrx",
- version = "6.4",
+ version = "6.5",
description = "Script to intelligently extract multiple archive types",
author = "Brett Smith",
author_email = "brettcsmith@brettcsmith.org",
url = "http://www.brettcsmith.org/2007/dtrx/",
+ download_url = "http://www.brettcsmith.org/2007/dtrx/",
scripts = ['scripts/dtrx'],
- license = "GNU General Public License, version 3 or later"
- )
+ license = "GNU General Public License, version 3 or later",
+ classifiers = ['Development Status :: 5 - Production/Stable',
+ 'Environment :: Console',
+ 'Intended Audience :: End Users/Desktop',
+ 'Intended Audience :: System Administrators',
+ 'License :: OSI Approved :: GNU General Public License (GPL)',
+ 'Natural Language :: English',
+ 'Operating System :: POSIX',
+ 'Programming Language :: Python',
+ 'Topic :: Utilities'],
+ long_description = """dtrx extracts archives in a number of different
+ formats; it currently supports tar, zip (including self-extracting
+ .exe files), cpio, rpm, deb, gem, 7z, cab, rar, and InstallShield
+ files. It can also decompress files compressed with gzip, bzip2,
+ lzma, or compress.
+
+ In addition to providing one command to handle many different archive
+ types, dtrx also aids the user by extracting contents consistently.
+ By default, everything will be written to a dedicated directory
+ that's named after the archive. dtrx will also change the
+ permissions to ensure that the owner can read and write all those
+ files."""
+ )