summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-05-14 09:44:19 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-05-15 15:29:59 +0200
commit058fb319964e739f3e5afa51ced3d1e25653a3f6 (patch)
tree71958aabc49f6f0154a3a479a818cd83345b7cde /Makefile.am
parent5ea846cc5197682d07ee46398996a8c3ccfbcc38 (diff)
readahead: add test to show fs_on_ssd() result
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 89b1d4e08..6379262ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3682,6 +3682,19 @@ nodist_systemunit_DATA += \
units/systemd-readahead-replay.service \
units/systemd-readahead-done.service
+manual_tests += \
+ test-ssd
+
+test_ssd_SOURCES = \
+ src/readahead/test-ssd.c \
+ src/readahead/readahead-common.c \
+ src/readahead/readahead-common.h
+
+test_ssd_LDADD = \
+ libsystemd-internal.la \
+ libudev-internal.la \
+ libsystemd-shared.la
+
endif
EXTRA_DIST += \