summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRonny Chevalier <chevalier.ronny@gmail.com>2014-11-11 20:05:40 +0100
committerTom Gundersen <teg@jklm.no>2014-11-13 10:39:51 +0100
commit281e05b6cb406debe7b290e5aee8eae049671c14 (patch)
treeee124bff7761e50b38a46745c1b110837f3cf7bd /Makefile.am
parent07aa32e31d82d1239a618e07adedaecd35d96b27 (diff)
tests: add test-execute
add tests for the following directives: - WorkingDirectory - Personality - IgnoreSIGPIPE - PrivateTmp - SystemCallFilter: It makes test/TEST-04-SECCOMP obsolete, so it has been removed. - SystemCallErrorNumber - User - Group - Environment
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0b32639fa..701666c27 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1350,6 +1350,7 @@ tests += \
test-uid-range \
test-bus-policy \
test-locale-util \
+ test-execute \
test-copy
EXTRA_DIST += \
@@ -1805,6 +1806,15 @@ test_path_CFLAGS = \
test_path_LDADD = \
libsystemd-core.la
+test_execute_SOURCES = \
+ src/test/test-execute.c
+
+test_execute_CFLAGS = \
+ $(AM_CFLAGS)
+
+test_execute_LDADD = \
+ libsystemd-core.la
+
test_strxcpyx_SOURCES = \
src/test/test-strxcpyx.c