summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2017-01-26 08:14:54 +0100
committerSven Eden <yamakuzure@gmx.net>2017-03-14 10:23:02 +0100
commit35ed426f81eb72dc23ce2dcc625ea88be1c95990 (patch)
tree3beface5e488f1d3acc0dbd78be8c1fbc8e13c02 /Makefile.am
parentc40fa3382a1b90aa5bccf2b36276e717461b11b0 (diff)
[Patch 1/3] Add cgroups initialization and handling
Re-add elogind-cgroups-agent. elogind will not be able to support the new unified hierarchy, and the agent is needed for the classical hierarchy.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 636924caf..2f9ec71f5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -115,6 +115,7 @@ CLEANFILES = $(BUILT_SOURCES) \
AM_CPPFLAGS = \
-include $(top_builddir)/config.h \
-DPKGSYSCONFDIR=\"$(pkgsysconfdir)\" \
+ -DELOGIND_CGROUP_AGENT_PATH=\"$(rootlibexecdir)/elogind-cgroups-agent\" \
-DROOTPREFIX=\"$(rootprefix)\" \
-DUDEVLIBEXECDIR=\"$(udevlibexecdir)\" \
-DPOLKIT_AGENT_BINARY_PATH=\"$(bindir)/pkttyagent\" \
@@ -457,6 +458,16 @@ dist_factory_pam_DATA = \
endif
# ------------------------------------------------------------------------------
+rootlibexec_PROGRAMS += \
+ elogind-cgroups-agent
+
+elogind_cgroups_agent_SOURCES = \
+ src/cgroups-agent/cgroups-agent.c
+
+elogind_cgroups_agent_LDADD = \
+ libshared.la
+
+# ------------------------------------------------------------------------------
libelogind_internal_la_SOURCES = \
src/systemd/sd-bus.h \
src/systemd/sd-bus-protocol.h \