summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2010-05-18 00:28:39 +0200
committerLennart Poettering <lennart@poettering.net>2010-05-18 00:28:39 +0200
commit42e39f0b326d27f6392a81a7400f9af7cf0af3ab (patch)
treeadd3721ae2fe419a5f0c5f76246007c8039384d4 /Makefile.am
parent53f7d807bff9c39e9e565ad2fb20f29b4306af40 (diff)
build-sys: remove vala generated sources only when valac is around
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 65ab1339a..e6366dd00 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -335,9 +335,6 @@ units/session/%: units/%.m4 Makefile
$(M4_PROCESS_SESSION)
CLEANFILES = \
- src/systemd-interfaces.c \
- src/systemctl.c \
- src/systemadm.c \
units/systemd-initctl.service \
units/systemd-logger.service \
units/syslog.target \
@@ -350,6 +347,13 @@ CLEANFILES = \
man/systemd.special.7 \
man/systemd.special.html
+if HAVE_VALAC
+CLEANFILES += \
+ src/systemd-interfaces.c \
+ src/systemctl.c \
+ src/systemadm.c
+endif
+
if HAVE_XSLTPROC
XSLTPROC_PROCESS_MAN = \
$(AM_V_GEN)$(MKDIR_P) $(dir $@) && \