summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2015-02-27 17:26:26 -0500
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2015-02-27 17:28:03 -0500
commit83e7d8850c38baee0da3097f27e191359aa70006 (patch)
treed06bbac90ccb62d90688b3334ce4e4b9496eafc8 /Makefile.am
parentea24d8d1383e038d6b6e599d42c0114b3dbd8acb (diff)
build-sys: make systemd-user-sessions conditional on PAM again
This undoes a part of previous commit: s-u-s is dependent on HAVE_PAM again, but not on HAVE_LOGIND.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am44
1 files changed, 29 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index 5847bb4ae..751f44c2b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -393,8 +393,7 @@ rootlibexec_PROGRAMS = \
systemd-sleep \
systemd-bus-proxyd \
systemd-socket-proxyd \
- systemd-update-done \
- systemd-user-sessions
+ systemd-update-done
if HAVE_UTMP
rootlibexec_PROGRAMS += \
@@ -555,8 +554,7 @@ nodist_systemunit_DATA = \
units/initrd-udevadm-cleanup-db.service \
units/initrd-switch-root.service \
units/systemd-nspawn@.service \
- units/systemd-update-done.service \
- units/systemd-user-sessions.service
+ units/systemd-update-done.service
if HAVE_UTMP
nodist_systemunit_DATA += \
@@ -609,8 +607,7 @@ EXTRA_DIST += \
units/initrd-udevadm-cleanup-db.service.in \
units/initrd-switch-root.service.in \
units/systemd-nspawn@.service.in \
- units/systemd-update-done.service.in \
- units/systemd-user-sessions.service.in
+ units/systemd-update-done.service.in
CLEANFILES += \
units/console-shell.service.m4 \
@@ -2126,13 +2123,6 @@ systemd_update_done_LDADD = \
libsystemd-shared.la
# ------------------------------------------------------------------------------
-systemd_user_sessions_SOURCES = \
- src/user-sessions/user-sessions.c
-
-systemd_user_sessions_LDADD = \
- libsystemd-shared.la
-
-# ------------------------------------------------------------------------------
systemd_shutdownd_SOURCES = \
src/shutdownd/shutdownd.c
@@ -6015,6 +6005,7 @@ pamlib_LTLIBRARIES = \
dist_pamconf_DATA = \
src/login/systemd-user
+
endif
nodist_systemunit_DATA += \
@@ -6074,6 +6065,30 @@ EXTRA_DIST += \
units/systemd-logind.service.in
# ------------------------------------------------------------------------------
+if HAVE_PAM
+
+systemd_user_sessions_SOURCES = \
+ src/user-sessions/user-sessions.c
+
+systemd_user_sessions_LDADD = \
+ libsystemd-shared.la
+
+rootlibexec_PROGRAMS += \
+ systemd-user-sessions
+
+nodist_systemunit_DATA += \
+ units/systemd-user-sessions.service
+
+EXTRA_DIST += \
+ units/systemd-user-sessions.service.in
+
+MULTI_USER_TARGET_WANTS += \
+ systemd-user-sessions.service
+
+endif
+
+# ------------------------------------------------------------------------------
+
if HAVE_PYTHON_DEVEL
pkgpyexec_LTLIBRARIES = \
_journal.la \
@@ -6596,8 +6611,7 @@ LOCAL_FS_TARGET_WANTS += \
MULTI_USER_TARGET_WANTS += \
getty.target \
- systemd-ask-password-wall.path \
- systemd-user-sessions.service
+ systemd-ask-password-wall.path
SYSINIT_TARGET_WANTS += \
dev-hugepages.mount \