summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDidier Roche <didrocks@ubuntu.com>2014-11-24 10:12:06 +0100
committerLennart Poettering <lennart@poettering.net>2014-12-03 03:41:19 +0100
commita1405db67c9fa6e8d734933cc7dd208bdb703cae (patch)
tree310a62436d9cb3834ec092232f4a6cde1191bf2d /Makefile.am
parent3fb394369ccd6787f8f883e0f81dc7f35cb1ec51 (diff)
machine-id-commit: add unit file
The unit file only active the machine-id-commit helper if /etc is mounted writable and /etc/machine-id is an independant mount point (should be a tmpfs).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2efd0333f..5b46243e6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -537,6 +537,7 @@ nodist_systemunit_DATA = \
units/systemd-kexec.service \
units/systemd-fsck@.service \
units/systemd-fsck-root.service \
+ units/systemd-machine-id-commit.service \
units/systemd-udevd.service \
units/systemd-udev-trigger.service \
units/systemd-udev-settle.service \
@@ -589,6 +590,7 @@ EXTRA_DIST += \
units/user/systemd-exit.service.in \
units/systemd-fsck@.service.in \
units/systemd-fsck-root.service.in \
+ units/systemd-machine-id-commit.service.in \
units/user@.service.in \
units/debug-shell.service.in \
units/systemd-suspend.service.in \
@@ -2227,6 +2229,9 @@ systemd_machine_id_commit_LDADD = \
libsystemd-internal.la \
libsystemd-shared.la
+SYSINIT_TARGET_WANTS += \
+ systemd-machine-id-commit.service
+
# ------------------------------------------------------------------------------
systemd_ac_power_SOURCES = \
src/ac-power/ac-power.c