summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2013-03-04 23:20:16 +0100
committerMichael Biebl <biebl@debian.org>2013-03-04 23:23:06 +0100
commitd51167c6268d11f02c2676693a8e9dc1b628cdbb (patch)
tree88436f2b2f06cd7c8323402d9f6bc8de7cc67d99 /Makefile.am
parent135b5212d4234f5b75c9b86c9f924047c8d07589 (diff)
build-sys: build and install systemd-coredumpctl conditionally
If coredump support is disabled via --disable-coredump, do not build and install the systemd-coredumpctl binary and man page.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 13 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index e23a6b448..3d3f2652f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -318,7 +318,6 @@ systemd_analyze_LDADD = \
dist_bashcompletion_DATA = \
shell-completion/bash/journalctl \
shell-completion/bash/systemctl \
- shell-completion/bash/systemd-coredumpctl \
shell-completion/bash/udevadm
dist_tmpfiles_DATA = \
@@ -2376,13 +2375,6 @@ journalctl_LDADD += \
$(QRENCODE_LIBS)
endif
-systemd_coredumpctl_SOURCES = \
- src/journal/coredumpctl.c
-
-systemd_coredumpctl_LDADD = \
- libsystemd-shared.la \
- libsystemd-journal.la
-
test_journal_SOURCES = \
src/journal/test-journal.c
@@ -2627,7 +2619,6 @@ rootbin_PROGRAMS += \
journalctl
bin_PROGRAMS += \
- systemd-coredumpctl \
systemd-cat
dist_systemunit_DATA += \
@@ -2719,6 +2710,19 @@ endif
rootlibexec_PROGRAMS += \
systemd-coredump
+systemd_coredumpctl_SOURCES = \
+ src/journal/coredumpctl.c
+
+systemd_coredumpctl_LDADD = \
+ libsystemd-shared.la \
+ libsystemd-journal.la
+
+bin_PROGRAMS += \
+ systemd-coredumpctl
+
+dist_bashcompletion_DATA += \
+ shell-completion/bash/systemd-coredumpctl
+
sysctl_DATA = \
sysctl.d/coredump.conf