summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2012-12-23 11:27:20 +0100
committerLennart Poettering <lennart@poettering.net>2012-12-23 11:28:14 +0100
commitf934051c4d17d167bd8e46dd3c70a745e26fd2eb (patch)
tree55ad4d1366fd960a1afeb76d6be4f5b619e4da26 /Makefile.am
parente8bc0ea2b100158bf35c635039226235aa879068 (diff)
shared: move fdset.c from core/ to shared/ since it is used by more than the core now
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 65055b3fb..165b85dea 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -801,6 +801,8 @@ libsystemd_shared_la_SOURCES = \
src/shared/hashmap.h \
src/shared/set.c \
src/shared/set.h \
+ src/shared/fdset.c \
+ src/shared/fdset.h \
src/shared/strv.c \
src/shared/strv.h \
src/shared/strbuf.c \
@@ -1057,8 +1059,6 @@ libsystemd_core_la_SOURCES = \
src/core/mount-setup.h \
src/core/loopback-setup.h \
src/core/loopback-setup.c \
- src/core/fdset.c \
- src/core/fdset.h \
src/core/condition.c \
src/core/condition.h \
src/core/namespace.c \
@@ -1670,9 +1670,7 @@ systemd_nspawn_SOURCES = \
src/core/mount-setup.c \
src/core/mount-setup.h \
src/core/loopback-setup.c \
- src/core/loopback-setup.h \
- src/core/fdset.c \
- src/core/fdset.h
+ src/core/loopback-setup.h
systemd_nspawn_LDADD = \
libsystemd-label.la \