summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2013-11-07 17:51:09 +0100
committerLennart Poettering <lennart@poettering.net>2013-11-07 17:51:09 +0100
commitfa57130d35dd8fd8c3f2f2126dd7fc6930a08e35 (patch)
tree139a8db9922a2d484e2a6b8e78760481bd06783c /Makefile.am
parenta27e222b58824c08fa0da18106cf28a02b6c5e23 (diff)
man: add docs for sd_is_special() and some man page symlinks
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 86baae0e7..df552e3a0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4576,7 +4576,7 @@ valgrind-tests: $(TESTS)
[ "$$f" == "$${f/.pl/}" ] && libtool --mode=execute valgrind --leak-check=full --error-exitcode=55 $(builddir)/$$f ; \
done
-check-api-docs: $(lib_LTLIBRARIES)
+check-api-docs: $(lib_LTLIBRARIES) man
for symbol in `for f in $(lib_LTLIBRARIES) ; do nm -g --defined-only $(builddir)/.libs/"$${f/.la/.so}" 2>&1 /dev/null | grep " T " | cut -d" " -f3 ; done` ; do \
if test -f $(builddir)/man/$$symbol.html ; then \
echo " Symbol $$symbol() is documented." ; \