summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Marineau <michael.marineau@coreos.com>2014-06-20 13:46:04 -0700
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-06-22 12:26:09 -0400
commit972bded03215d4602fdd2ed2d680350c8eacb056 (patch)
tree8087706cf13aef694e18b7380c8652bf3a0f010c /configure.ac
parentc305edb643130cbb2a9cc1414c216e21d227f32f (diff)
build-sys: require elfutils >= 158
The recently added stacktrace support in 8d4e028f uses functions added in elfutils 158. Check for one of the new functions to avoid attempting to build against older versions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 18e934c38..bb6018f87 100644
--- a/configure.ac
+++ b/configure.ac
@@ -672,7 +672,7 @@ AC_ARG_ENABLE([elfutils],
if test "x${have_elfutils}" != xno ; then
AC_CHECK_HEADERS(
[elfutils/libdwfl.h],
- [have_elfutils=yes],
+ [],
[if test "x$have_elfutils" = xyes ; then
AC_MSG_ERROR([*** ELFUTILS headers not found.])
fi])
@@ -680,11 +680,19 @@ if test "x${have_elfutils}" != xno ; then
AC_CHECK_LIB(
[dw],
[dwfl_begin],
- [have_elfutils=yes],
+ [],
[if test "x$have_elfutils" = xyes ; then
AC_MSG_ERROR([*** ELFUTILS libs not found.])
fi])
+ AC_CHECK_LIB(
+ [dw],
+ [dwfl_core_file_attach],
+ [have_elfutils=yes],
+ [if test "x$have_elfutils" = xyes ; then
+ AC_MSG_ERROR([*** ELFUTILS >= 158 is required.])
+ fi])
+
if test "x$have_elfutils" = xyes ; then
ELFUTILS_LIBS="-lelf -ldw"
AC_DEFINE(HAVE_ELFUTILS, 1, [ELFUTILS available])