summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFilipe Brandenburger <filbranden@google.com>2014-06-24 23:06:46 -0700
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-06-26 01:41:05 -0400
commitf15515b5e6a9ebe95c938cc670df6e576fcf9176 (patch)
tree88efafc0bbe4f5bc7322696795cfdac6292f2a3b /configure.ac
parent2f96919bcdd0978164c801b21e053fb3b31e8bac (diff)
build-sys: disable NLS support if intltool is not found
IT_PROG_INTLTOOL makes configure fail if intltool is not present. If we can not find intltool, then disable NLS (otherwise make in po/ fails since MSGFMT will not be defined.) Tested: Built it on a host without intltool. $ ./configure --enable-nls ... checking for intltool-merge... no configure: error: --enable-nls requested but intltool not found $ ./configure --disable-polkit ... checking for intltool-merge... no configure: WARNING: *** Disabling NLS support because intltool was not found checking whether NLS is requested... no ... $ make https://bugs.freedesktop.org/show_bug.cgi?id=79692
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 31879d3fb..93aba0673 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,6 +49,18 @@ AS_IF([test "x$enable_static" = "xyes"], [AC_MSG_ERROR([--enable-static is not s
AS_IF([test "x$enable_largefile" = "xno"], [AC_MSG_ERROR([--disable-largefile is not supported by systemd])])
# i18n stuff for the PolicyKit policy files
+
+# Check whether intltool can be found, disable NLS otherwise
+AC_CHECK_PROG(intltool_found, [intltool-merge], [yes], [no])
+AS_IF([test x"$intltool_found" != xyes],
+ [AS_IF([test x"$enable_nls" = xyes],
+ [AC_MSG_ERROR([--enable-nls requested but intltool not found])],
+ [AS_IF([test x"$enable_nls" != xno],
+ [AC_MSG_WARN([*** Disabling NLS support because intltool was not found])
+ enable_nls=no])
+ ])
+ ])
+
AM_NLS
AS_IF([test x"$enable_nls" != xno], [
# intltoolize greps for '^(AC|IT)_PROG_INTLTOOL', so it needs to be on its own line