summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristoph Willing <chris.willing@linux.com>2018-09-26 23:14:02 +1000
committerSven Eden <yamakuzure@gmx.net>2018-09-26 18:29:59 +0200
commitb0c24eee5154ec046725b108fdb3cded008afc00 (patch)
tree4dab9cc8087b06ac13b687d48de3393683a1d81c /meson.build
parent938f002d22d44380b2087a43ef1666cb762434cd (diff)
Support system_bus_socket to be found in /var/run/dbus as well as /run/dbus.
Currently the path to system_bus_socket is hardcoded to /run/dbus/system_bus_socket which works everywhere for systemd. However, distributions which do no symlink /var/run on /run will have it only accessible via /run/dbus/system_bus_socket which should be supported by elogind, too. Closes #77 Signed-off-by: Christoph Willing <chris.willing@linux.com> Sigend-off-by: Sven Eden <sven.eden@prydeworx.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 45262dcff..550d7a674 100644
--- a/meson.build
+++ b/meson.build
@@ -204,6 +204,12 @@ if dbussystemservicedir == ''
dbussystemservicedir = join_paths(datadir, 'dbus-1/system-services')
endif
+#if 1 /// Will elogind find system_bus_socket in /run/dbus or /var/run/dbus ?
+varrunissymllink = run_command('test', '-L', '/var/run').returncode() == 0
+message('Setting VARRUN_IS_SYMLINK to: @0@'.format(varrunissymllink))
+conf.set10('VARRUN_IS_SYMLINK', varrunissymllink)
+#endif // 1
+
pamlibdir = get_option('pamlibdir')
if pamlibdir == ''
pamlibdir = join_paths(rootlibdir, 'security')