summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2024-03-21 19:22:35 +0800
committerSean Whitton <spwhitton@spwhitton.name>2024-03-21 19:22:35 +0800
commitc7b87a9f357ea5ad561a2c8468ec2c35432fe136 (patch)
tree0f12009ea8e3376b235d7654d9d4f206852bb6a5
parentd65e3752643994f1e5b25e91b5d7bd9262862178 (diff)
Delete textual duplicate of kvaq ert-deftest
-rw-r--r--debian/changelog1
-rw-r--r--kv-tests.el7
2 files changed, 1 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index cae560e..faa7a39 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,7 @@ emacs-kv (0.0.19+git20140108.7211484-5) UNRELEASED; urgency=medium
[ Sean Whitton ]
* Add source package configuration for dgit-maint-merge(7).
+ * Delete textual duplicate of kvaq ert-deftest (Closes: #1052933).
-- Nicholas D Steeves <sten@debian.org> Wed, 28 Jul 2021 18:28:57 -0400
diff --git a/kv-tests.el b/kv-tests.el
index 1713e5e..abd6a24 100644
--- a/kv-tests.el
+++ b/kv-tests.el
@@ -105,13 +105,6 @@
(should-not (equal "b" (kvaq "a" '((:a . :b)("a" . "b")))))
(should-not (kvaq "b" '((:a . :b)("a" . "b")))))
-(ert-deftest kvaq ()
- "Test the simple assq."
- (should (equal :b (kvaq :a '((:a . :b)("a" . "b")))))
- (should (equal 2 (kvaq 1 '((1 . 2)("a" . "b")))))
- (should-not (equal "b" (kvaq "a" '((:a . :b)("a" . "b")))))
- (should-not (kvaq "b" '((:a . :b)("a" . "b")))))
-
(ert-deftest kvaqc ()
"Test the simple assq."
(should (equal :b (kvaqc :a '((:a . :b)("a" . "b")))))