summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2013-04-09 14:03:53 +0100
committerP. F. Chimento <philip.chimento@gmail.com>2013-04-17 17:15:52 +0200
commit5049b8938f407629690c6682263187986fb5f2ba (patch)
treeaaed4d880af24856a37c8e48918b20f3d2819fb0 /Makefile.am
parent89671a4914caf1e20ea20a19c6bff7a058ebb3c4 (diff)
Add test framework
There are automated tests which run when you do 'make check', and also smoke tests which demonstrate one piece of functionality, which can be used as a sort of sanity check or demo. [#1]
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d4a27a0..11a922e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,6 +20,8 @@ EXTRA_DIST = @EOS_SDK_API_NAME@.pc.in
DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
AM_CFLAGS = @STRICT_CFLAGS@
+# Generated files that 'make clean' should erase
+CLEANFILES =
DISTCLEANFILES =
# # # LIBRARY # # #
@@ -37,3 +39,13 @@ nobase_endlessinclude_HEADERS = \
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = @EOS_SDK_API_NAME@.pc
DISTCLEANFILES += @EOS_SDK_API_NAME@.pc
+
+# # # TESTS # # #
+
+include $(top_srcdir)/test/Makefile.am
+
+# Run tests when running 'make check'
+TESTS_ENVIRONMENT = gtester -k -o test-results.xml
+TESTS = test/run-tests
+
+CLEANFILES += test-results.xml