summaryrefslogtreecommitdiff
path: root/autogen.sh
diff options
context:
space:
mode:
authorMatt Watson <mattdangerw@gmail.com>2013-06-19 23:48:51 -0700
committerMatt Watson <mattdangerw@gmail.com>2013-06-20 00:02:50 -0700
commit41cf9468100fdedb48af0f5658877a0a2c49e5b8 (patch)
tree62706129cdcf57479faf538af39973b527376ce7 /autogen.sh
parentdde468286c1a240da7bd509a67a3d0619432142e (diff)
Added hack so configure works with automake 1.13 and 1.11
The problem was with needing the serial-tests option in 1.13 More details here http://gnu-automake.7480.n7.nabble.com/serial-tests-option-and-backwards-compatibility-td19571.html
Diffstat (limited to 'autogen.sh')
-rwxr-xr-xautogen.sh9
1 files changed, 9 insertions, 0 deletions
diff --git a/autogen.sh b/autogen.sh
index 6c20886..6ff77fb 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -32,6 +32,15 @@ if test -z "$NOCONFIGURE"; then
echo "environment."
fi
+am_ver=`automake --version | grep -m 1 -o '[^ ]*$'`
+# Autmake 1.11.x doesn't grasp the 'serial-tests' option. Add a m4 file which
+# defines HAS_SERIAL_TESTS_OPTION so we can keep our configure.ac forward
+# compatible
+case $am_ver in
+ *\ 1.11*|*\ 1.12*) ;;
+ *) echo 'm4_define([HAS_SERIAL_TESTS_OPTION], [1])';;
+esac > m4/serial-tests.m4
+
# Run the actual tools to prepare the clean checkout
gtkdocize || exit $?
autoreconf -fi || exit $?