summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorSam Spilsbury <smspillaz@gmail.com>2015-06-17 06:46:08 +0800
committerSam Spilsbury <smspillaz@gmail.com>2015-07-21 08:47:03 +0800
commit8b90ed61058bc2c51e325ad8b116390413ff930b (patch)
tree16f634e4b223b6a46816477e51ec353630c59234 /test
parentacfb7bdb156aecdc58f8dae8103e78e7ccaed6e2 (diff)
eos-coverage: Add run_coverage.coverage "test"
This test automatically generates a coverage report at the completion of all other tests. It exists as a pseudo-test which depends on the completion of every other test. Effectively, coverage reports are now generated automatically when --enable-coverage is specified, though you can also run make coverage-cobertura and make coverage-genhtml to update them otherwise. The burden on packages is that they must add .coverage to TEST_EXTENSIONS and add run_coverage.coverage to TESTS. [endlessm/eos-sdk#3303]
Diffstat (limited to 'test')
-rw-r--r--test/Makefile.am.inc3
1 files changed, 2 insertions, 1 deletions
diff --git a/test/Makefile.am.inc b/test/Makefile.am.inc
index d927da8..bfc0a11 100644
--- a/test/Makefile.am.inc
+++ b/test/Makefile.am.inc
@@ -62,10 +62,11 @@ EXTRA_DIST += \
TESTS = \
test/endless/run-tests \
$(javascript_tests) \
+ run_coverage.coverage \
$(NULL)
JS_LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(top_srcdir)/test/run-with-dbus --session $(SHELL) $(top_srcdir)/tap-driver.sh
JS_LOG_DRIVER_FLAGS = --comments
-TEST_EXTENSIONS = .js
+TEST_EXTENSIONS = .js .coverage
JS_LOG_COMPILER = jasmine
AM_JS_LOG_FLAGS = \
--include-path=$(top_srcdir)/webhelper \