summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2015-04-17 13:08:00 -0700
committerPhilip Chimento <philip@endlessm.com>2015-04-17 13:09:01 -0700
commite9e71b98bbb4d1b31322488a6ef051e022635ad4 (patch)
treed5077acf82e0331ad9ac62266804bfc25495985f /test
parent3fc99841e7b72cd664939fce5a67359da1eab82b (diff)
Switch to subdir-objects
This requires removing the $(ENDLESS_TESTS_DIRECTORY) variable, which wasn't really necessary anyway. Subdir-objects would like you to specify your directories directly in the rule target names. [endlessm/eos-sdk#3054]
Diffstat (limited to 'test')
-rw-r--r--test/Makefile.am.inc1
-rw-r--r--test/endless/Makefile.am.inc18
-rw-r--r--test/smoke-tests/Makefile.am.inc2
3 files changed, 10 insertions, 11 deletions
diff --git a/test/Makefile.am.inc b/test/Makefile.am.inc
index 5b3128a..c18defd 100644
--- a/test/Makefile.am.inc
+++ b/test/Makefile.am.inc
@@ -2,7 +2,6 @@
TEST_FLAGS = @EOS_SDK_CFLAGS@ -I$(top_srcdir) -DCOMPILING_EOS_SDK
TEST_LIBS = @EOS_SDK_LIBS@ $(top_builddir)/libendless-@EOS_SDK_API_VERSION@.la
-ENDLESS_TESTS_DIRECTORY = $(top_srcdir)/test
noinst_PROGRAMS = \
test/endless/run-tests \
diff --git a/test/endless/Makefile.am.inc b/test/endless/Makefile.am.inc
index 5e83d2f..628ad0f 100644
--- a/test/endless/Makefile.am.inc
+++ b/test/endless/Makefile.am.inc
@@ -1,15 +1,15 @@
# Copyright 2013 Endless Mobile, Inc.
test_endless_run_tests_SOURCES = \
- $(ENDLESS_TESTS_DIRECTORY)/endless/run-tests.c \
- $(ENDLESS_TESTS_DIRECTORY)/endless/run-tests.h \
- $(ENDLESS_TESTS_DIRECTORY)/endless/test-init.c \
- $(ENDLESS_TESTS_DIRECTORY)/endless/test-hello.c \
- $(ENDLESS_TESTS_DIRECTORY)/endless/test-application.c \
- $(ENDLESS_TESTS_DIRECTORY)/endless/test-page-manager.c \
- $(ENDLESS_TESTS_DIRECTORY)/endless/test-window.c \
- $(ENDLESS_TESTS_DIRECTORY)/endless/test-flexy-grid.c \
- $(ENDLESS_TESTS_DIRECTORY)/endless/test-custom-container.c \
+ test/endless/run-tests.c \
+ test/endless/run-tests.h \
+ test/endless/test-init.c \
+ test/endless/test-hello.c \
+ test/endless/test-application.c \
+ test/endless/test-page-manager.c \
+ test/endless/test-window.c \
+ test/endless/test-flexy-grid.c \
+ test/endless/test-custom-container.c \
$(NULL)
test_endless_run_tests_CPPFLAGS = $(TEST_FLAGS)
test_endless_run_tests_LDADD = $(TEST_LIBS)
diff --git a/test/smoke-tests/Makefile.am.inc b/test/smoke-tests/Makefile.am.inc
index 170b335..5ee5ac2 100644
--- a/test/smoke-tests/Makefile.am.inc
+++ b/test/smoke-tests/Makefile.am.inc
@@ -1,6 +1,6 @@
# Copyright 2013 Endless Mobile, Inc.
-test_smoke_tests_hello_SOURCES = $(ENDLESS_TESTS_DIRECTORY)/smoke-tests/hello.c
+test_smoke_tests_hello_SOURCES = test/smoke-tests/hello.c
test_smoke_tests_hello_CPPFLAGS = $(TEST_FLAGS)
test_smoke_tests_hello_LDADD = $(TEST_LIBS)