summaryrefslogtreecommitdiff
path: root/wikipedia
diff options
context:
space:
mode:
authorPhilip Chimento <philip@endlessm.com>2013-07-08 16:36:54 -0700
committerPhilip Chimento <philip@endlessm.com>2013-10-18 14:02:26 -0700
commit9d0850b4fb74d21f7e3a5189567ef80fc0239b75 (patch)
treeb0fb93c7861eb8e471d1ddc49b064c6288d96dd1 /wikipedia
parent60369d32ec26deba64766b58b4470d7b9c8a629f (diff)
'eos-application-manifest' tool with subcommands
This is the framework for an 'eos-application-manifest' tool with subcommands as in git. Currently the 'help' and 'version' subcommands are implemented. [endlessm/eos-sdk#152]
Diffstat (limited to 'wikipedia')
-rw-r--r--wikipedia/Makefile.am.inc4
1 files changed, 2 insertions, 2 deletions
diff --git a/wikipedia/Makefile.am.inc b/wikipedia/Makefile.am.inc
index c816f5b..6f214d1 100644
--- a/wikipedia/Makefile.am.inc
+++ b/wikipedia/Makefile.am.inc
@@ -5,13 +5,13 @@
# Create a config.js file with the installed directory locations. Use the
# following sed script to replace $datadir inside the script, as suggested by
# the Autoconf manual; because $datadir and friends only work inside Makefiles.
-edit = sed \
+wikipedia_edit = sed \
-e 's|@datadir[@]|$(datadir)|g' \
$(NULL)
wikipedia/config.js: wikipedia/config.js.in Makefile
$(AM_V_GEN)mkdir -p wikipedia && \
rm -f $@ $@.tmp && \
- $(edit) $< >$@.tmp && \
+ $(wikipedia_edit) $< >$@.tmp && \
chmod +x $@.tmp && \
chmod a-w $@.tmp && \
mv $@.tmp $@