summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ce67ced..51ac18b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -59,9 +59,17 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = @EOS_SDK_API_NAME@.pc
DISTCLEANFILES += @EOS_SDK_API_NAME@.pc
-# SDK sublibraries
+# # # WEBHELPER LIBRARY # # #
+
+webhelper_sources = webhelper/webhelper.js
+
gjsmodulesdir = $(datadir)/gjs-1.0
-include $(top_srcdir)/webhelper/Makefile.am.inc
+webhelperdir = $(gjsmodulesdir)
+dist_webhelper_DATA = \
+ $(webhelper_sources) \
+ $(NULL)
+
+EOS_JS_COVERAGE_FILES = $(webhelper_sources)
# # # INTROSPECTION FILES # # #