summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorWill Estes <wlestes@users.sourceforge.net>2002-09-23 16:02:29 +0000
committerWill Estes <wlestes@users.sourceforge.net>2002-09-23 16:02:29 +0000
commitfbc72d8bfec5848259d77e4ff0b1b742a07dbfe6 (patch)
tree28e726633ce85c8529682b5f08d5637f01d61e17 /tests
parentb3433aa5d51c0b7954ec5a43dc145870e16bbe6d (diff)
DIST_SUBDIRS so we don't have to run the TEMPLATE test; so we add new tests to SUBDIRS and DIST_SUBDIRS
Diffstat (limited to 'tests')
-rw-r--r--tests/Makefile.am36
-rwxr-xr-xtests/create-test2
2 files changed, 36 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 95e3405..09308c3 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -25,7 +25,7 @@ EXTRA_DIST = \
noinst_SCRIPTS = \
create-test
-SUBDIRS = \
+DIST_SUBDIRS = \
test-reject \
test-bison-nr \
test-c++-basic \
@@ -60,6 +60,40 @@ SUBDIRS = \
test-yyextra \
test-table-opts
+SUBDIRS = \
+ test-reject \
+ test-bison-nr \
+ test-c++-basic \
+ test-posixly-correct \
+ test-posix \
+ test-mem-r \
+ test-mem-nr \
+ test-debug-nr \
+ test-debug-r \
+ test-lineno-r \
+ test-lineno-nr \
+ test-array-nr \
+ test-array-r \
+ test-basic-nr \
+ test-basic-r \
+ test-bison-yylloc \
+ test-bison-yylval \
+ test-c-cpp-nr \
+ test-c-cpp-r \
+ test-header-nr \
+ test-header-r \
+ test-include-by-buffer \
+ test-include-by-reentrant \
+ test-multiple-scanners-nr \
+ test-multiple-scanners-r \
+ test-prefix-nr \
+ test-prefix-r \
+ test-pthread \
+ test-string-nr \
+ test-string-r \
+ test-yyextra \
+ test-table-opts
+
# clean up before running the test suite so we dont test old builds of test code
test: clean
diff --git a/tests/create-test b/tests/create-test
index 44c339b..e02c2c0 100755
--- a/tests/create-test
+++ b/tests/create-test
@@ -31,7 +31,7 @@ tests/'"$1"'/Makefile' < ../configure.in > configure.in.tmp
mv configure.in.tmp ../configure.in
# Modify Makefile.am
-sed '/^SUBDIRS/a\
+sed '/^\(DIST_\)\?SUBDIRS/a\
'"$1"' \\' < Makefile.am > Makefile.am.tmp
mv Makefile.am.tmp Makefile.am