summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2011-08-19 15:02:34 +0200
committerDidier Raboud <odyx@debian.org>2011-08-19 15:02:34 +0200
commit15503fc39db0ea3ede7a60960c48562009378dbb (patch)
treec0a7675888d2f098af7b1ea7e2e4e4b0316439d7 /debian/rules
parent21f39290acbbccbbf80326d6f26373ed1842c710 (diff)
Compile the PPDs with no more jobs than specified in DEB_BUILD_OPTIONS, per policy.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 0e634245..068cb4d3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,10 @@
derives_from_ubuntu := $(shell (dpkg-vendor --derives-from Ubuntu && echo "yes") || echo "no")
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+endif
+
%:
dh $@
@@ -39,7 +43,7 @@ override_dh_install:
mkdir -p $(CURDIR)/debian/foomatic-db-compressed-ppds/usr/share/ppds/
# Pre-build PPD files for foomatic-db-compressed-ppds
- FOOMATICDB=$(CURDIR)/debian/foomatic-db/usr/share/foomatic foomatic-compiledb -j 16 -t ppd -d $(CURDIR)/debian/foomatic-db-compressed-ppds/usr/share/ppds/foomatic-ppds `ls -1 $(CURDIR)/debian/foomatic-db/usr/share/foomatic/db/source/driver/*.xml | perl -p -e 's:^.*db/source/driver/(\S*)\.xml\s*$$:\1\n:'`
+ FOOMATICDB=$(CURDIR)/debian/foomatic-db/usr/share/foomatic foomatic-compiledb -j $(NUMJOBS) -t ppd -d $(CURDIR)/debian/foomatic-db-compressed-ppds/usr/share/ppds/foomatic-ppds `ls -1 $(CURDIR)/debian/foomatic-db/usr/share/foomatic/db/source/driver/*.xml | perl -p -e 's:^.*db/source/driver/(\S*)\.xml\s*$$:\1\n:'`
dh_pyppd -popenprinting-ppds
dh_pyppd -pfoomatic-db-compressed-ppds