summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 0e634245..068cb4d3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,10 @@
derives_from_ubuntu := $(shell (dpkg-vendor --derives-from Ubuntu && echo "yes") || echo "no")
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+endif
+
%:
dh $@
@@ -39,7 +43,7 @@ override_dh_install:
mkdir -p $(CURDIR)/debian/foomatic-db-compressed-ppds/usr/share/ppds/
# Pre-build PPD files for foomatic-db-compressed-ppds
- FOOMATICDB=$(CURDIR)/debian/foomatic-db/usr/share/foomatic foomatic-compiledb -j 16 -t ppd -d $(CURDIR)/debian/foomatic-db-compressed-ppds/usr/share/ppds/foomatic-ppds `ls -1 $(CURDIR)/debian/foomatic-db/usr/share/foomatic/db/source/driver/*.xml | perl -p -e 's:^.*db/source/driver/(\S*)\.xml\s*$$:\1\n:'`
+ FOOMATICDB=$(CURDIR)/debian/foomatic-db/usr/share/foomatic foomatic-compiledb -j $(NUMJOBS) -t ppd -d $(CURDIR)/debian/foomatic-db-compressed-ppds/usr/share/ppds/foomatic-ppds `ls -1 $(CURDIR)/debian/foomatic-db/usr/share/foomatic/db/source/driver/*.xml | perl -p -e 's:^.*db/source/driver/(\S*)\.xml\s*$$:\1\n:'`
dh_pyppd -popenprinting-ppds
dh_pyppd -pfoomatic-db-compressed-ppds