summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2022-08-31 21:42:06 +0100
committerSimon McVittie <smcv@debian.org>2022-08-31 23:05:34 +0100
commit3fbc8bda1254130e1c947df99e1ac5c1548dcddd (patch)
tree0c83f95e30b6197e1d636fa680ecfa8f6403c5d6
parenta7b08fcc3132e488c36eabe45c14e60ff304b274 (diff)
d/rules, d/debug-test-failure: Show log on test failure
Normally dh_auto_test would automatically show the log, but because we're using a wrapper, the test does not have the expected filename.
-rwxr-xr-xdebian/debug-test-failure17
-rwxr-xr-xdebian/rules7
2 files changed, 18 insertions, 6 deletions
diff --git a/debian/debug-test-failure b/debian/debug-test-failure
new file mode 100755
index 00000000..03c62a5b
--- /dev/null
+++ b/debian/debug-test-failure
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+set -eu
+
+find obj-*/meson-logs -name testlog*.txt -exec head -n-0 -v '{}' ';'
+
+case "$DEB_HOST_ARCH" in
+ (amd64 | arm64 | armhf | i386 | mips64el | mipsel | ppc64el | s390x | riscv64)
+ exit 1
+ ;;
+
+ (*)
+ echo "Assuming tests are failing due to gjs being disabled"
+ echo "See https://gitlab.gnome.org/GNOME/glade/-/issues/495"
+ exit 0
+ ;;
+esac
diff --git a/debian/rules b/debian/rules
index 2e1a24f9..7bb589f5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -30,12 +30,7 @@ TEST_COMMAND = dh_auto_test -- --wrap="dbus-run-session -- xvfb-run -a" \
--timeout-multiplier 5
override_dh_auto_test:
-# Tests are failing without gjs support, see https://gitlab.gnome.org/GNOME/glade/-/issues/495
-ifeq (,$(filter $(DEB_HOST_ARCH), amd64 arm64 armhf i386 mips64el mipsel ppc64el s390x riscv64))
- $(TEST_COMMAND) || true
-else
- $(TEST_COMMAND)
-endif
+ $(TEST_COMMAND) || DEB_HOST_ARCH=$(DEB_HOST_ARCH) debian/debug-test-failure
# There's unclear precedent in the Debian archive for which package
# should install the ITS files. These files probably aren't needed yet anyway.