summaryrefslogtreecommitdiff
path: root/plugins/gtk+/glade-entry-editor.c
diff options
context:
space:
mode:
authorTristan Van Berkom <tvb@gnome.org>2009-01-27 21:15:59 +0000
committerTristan Van Berkom <tvb@src.gnome.org>2009-01-27 21:15:59 +0000
commitf8dc325b555700536f99d06292360b96c0c647dd (patch)
tree62eeae49f0ea90155bd4057c97f9b3bd65988786 /plugins/gtk+/glade-entry-editor.c
parentbd39a1e0781be66de4d2fca2d102bbc4dc67d4c3 (diff)
Bumping version for Anjuta dependancy
2009-01-27 Tristan Van Berkom <tvb@gnome.org> * configure.ac: Bumping version for Anjuta dependancy * plugins/gtk+/gtk+.xml.in: Added some metadata about GtkAction 2009-01-23 Tristan Van Berkom <tvb@gnome.org> * plugins/gtk+/glade-entry-editor.c, plugins/gtk+/glade-gtk.c, plugins/gtk+/gtk+.xml.in: updated for new GtkEntry property name changes. svn path=/trunk/; revision=2100
Diffstat (limited to 'plugins/gtk+/glade-entry-editor.c')
-rw-r--r--plugins/gtk+/glade-entry-editor.c28
1 files changed, 14 insertions, 14 deletions
diff --git a/plugins/gtk+/glade-entry-editor.c b/plugins/gtk+/glade-entry-editor.c
index b115d68b..e9bb1f98 100644
--- a/plugins/gtk+/glade-entry-editor.c
+++ b/plugins/gtk+/glade-entry-editor.c
@@ -206,10 +206,10 @@ glade_entry_editor_grab_focus (GtkWidget *widget)
}
-#define ICON_MODE_NAME(primary) ((primary) ? "primary-icon-mode" : "secondary-icon-mode")
-#define PIXBUF_NAME(primary) ((primary) ? "pixbuf-primary" : "pixbuf-secondary")
-#define ICON_NAME_NAME(primary) ((primary) ? "icon-name-primary" : "icon-name-secondary")
-#define STOCK_NAME(primary) ((primary) ? "stock-primary" : "stock-secondary")
+#define ICON_MODE_NAME(primary) ((primary) ? "primary-icon-mode" : "secondary-icon-mode")
+#define PIXBUF_NAME(primary) ((primary) ? "primary-icon-pixbuf" : "secondary-icon-pixbuf")
+#define ICON_NAME_NAME(primary) ((primary) ? "primary-icon-name" : "secondary-icon-name")
+#define STOCK_NAME(primary) ((primary) ? "primary-icon-stock" : "secondary-icon-stock")
static void
set_stock_mode (GladeEntryEditor *entry_editor, gboolean primary)
@@ -491,7 +491,7 @@ glade_entry_editor_new (GladeWidgetAdaptor *adaptor,
group = gtk_size_group_new (GTK_SIZE_GROUP_HORIZONTAL);
/* Pixbuf */
- eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "pixbuf-primary", FALSE, TRUE);
+ eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, PIXBUF_NAME(TRUE), FALSE, TRUE);
hbox = gtk_hbox_new (FALSE, 0);
entry_editor->primary_pixbuf_radio = gtk_radio_button_new (NULL);
gtk_box_pack_start (GTK_BOX (hbox), entry_editor->primary_pixbuf_radio, FALSE, FALSE, 2);
@@ -501,7 +501,7 @@ glade_entry_editor_new (GladeWidgetAdaptor *adaptor,
entry_editor->properties = g_list_prepend (entry_editor->properties, eprop);
/* Stock */
- eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "stock-primary", FALSE, TRUE);
+ eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, STOCK_NAME(TRUE), FALSE, TRUE);
hbox = gtk_hbox_new (FALSE, 0);
entry_editor->primary_stock_radio = gtk_radio_button_new_from_widget
(GTK_RADIO_BUTTON (entry_editor->primary_pixbuf_radio));
@@ -512,7 +512,7 @@ glade_entry_editor_new (GladeWidgetAdaptor *adaptor,
entry_editor->properties = g_list_prepend (entry_editor->properties, eprop);
/* Icon name */
- eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "icon-name-primary", FALSE, TRUE);
+ eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, ICON_NAME_NAME(TRUE), FALSE, TRUE);
hbox = gtk_hbox_new (FALSE, 0);
entry_editor->primary_icon_name_radio = gtk_radio_button_new_from_widget
(GTK_RADIO_BUTTON (entry_editor->primary_pixbuf_radio));
@@ -522,12 +522,12 @@ glade_entry_editor_new (GladeWidgetAdaptor *adaptor,
table_attach (table, GTK_WIDGET (eprop), 1, 2, group);
entry_editor->properties = g_list_prepend (entry_editor->properties, eprop);
- eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "activatable-primary", FALSE, TRUE);
+ eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "primary-icon-activatable", FALSE, TRUE);
table_attach (table, eprop->item_label, 0, 3, group);
table_attach (table, GTK_WIDGET (eprop), 1, 3, group);
entry_editor->properties = g_list_prepend (entry_editor->properties, eprop);
- eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "sensitive-primary", FALSE, TRUE);
+ eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "primary-icon-sensitive", FALSE, TRUE);
table_attach (table, eprop->item_label, 0, 4, group);
table_attach (table, GTK_WIDGET (eprop), 1, 4, group);
entry_editor->properties = g_list_prepend (entry_editor->properties, eprop);
@@ -554,7 +554,7 @@ glade_entry_editor_new (GladeWidgetAdaptor *adaptor,
group = gtk_size_group_new (GTK_SIZE_GROUP_HORIZONTAL);
/* Pixbuf */
- eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "pixbuf-secondary", FALSE, TRUE);
+ eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, PIXBUF_NAME(FALSE), FALSE, TRUE);
hbox = gtk_hbox_new (FALSE, 0);
entry_editor->secondary_pixbuf_radio = gtk_radio_button_new (NULL);
gtk_box_pack_start (GTK_BOX (hbox), entry_editor->secondary_pixbuf_radio, FALSE, FALSE, 2);
@@ -564,7 +564,7 @@ glade_entry_editor_new (GladeWidgetAdaptor *adaptor,
entry_editor->properties = g_list_prepend (entry_editor->properties, eprop);
/* Stock */
- eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "stock-secondary", FALSE, TRUE);
+ eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, STOCK_NAME(FALSE), FALSE, TRUE);
hbox = gtk_hbox_new (FALSE, 0);
entry_editor->secondary_stock_radio = gtk_radio_button_new_from_widget
(GTK_RADIO_BUTTON (entry_editor->secondary_pixbuf_radio));
@@ -575,7 +575,7 @@ glade_entry_editor_new (GladeWidgetAdaptor *adaptor,
entry_editor->properties = g_list_prepend (entry_editor->properties, eprop);
/* Icon name */
- eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "icon-name-secondary", FALSE, TRUE);
+ eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, ICON_NAME_NAME(FALSE), FALSE, TRUE);
hbox = gtk_hbox_new (FALSE, 0);
entry_editor->secondary_icon_name_radio = gtk_radio_button_new_from_widget
(GTK_RADIO_BUTTON (entry_editor->secondary_pixbuf_radio));
@@ -585,12 +585,12 @@ glade_entry_editor_new (GladeWidgetAdaptor *adaptor,
table_attach (table, GTK_WIDGET (eprop), 1, 2, group);
entry_editor->properties = g_list_prepend (entry_editor->properties, eprop);
- eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "activatable-secondary", FALSE, TRUE);
+ eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "secondary-icon-activatable", FALSE, TRUE);
table_attach (table, eprop->item_label, 0, 3, group);
table_attach (table, GTK_WIDGET (eprop), 1, 3, group);
entry_editor->properties = g_list_prepend (entry_editor->properties, eprop);
- eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "sensitive-secondary", FALSE, TRUE);
+ eprop = glade_widget_adaptor_create_eprop_by_name (adaptor, "secondary-icon-sensitive", FALSE, TRUE);
table_attach (table, eprop->item_label, 0, 4, group);
table_attach (table, GTK_WIDGET (eprop), 1, 4, group);
entry_editor->properties = g_list_prepend (entry_editor->properties, eprop);