summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron M. Ucko <ucko@debian.org>2019-01-20 22:21:29 -0500
committerAaron M. Ucko <ucko@debian.org>2019-01-20 22:49:49 -0500
commit14f2432b47dec4382527c0c3995920a2908f0bc6 (patch)
treefb822b46e00bc4bb86581ef5002c448f6d8e3c28
parent7ba5382ec38d663eb25682dd464aab811a5f7dab (diff)
Improve support for arch-only and indep-only builds.
* debian/control: Split out Build-Depends-Arch (lib*-dev) and -Indep (dh-elpa). * debian/goo.manpages: New, to avoid needing override_dh_installman. * debian/rules: Streamline builds that cover only architecture-dependent or -independent binary packages. - Limit use of --with elpa to binary and binary-indep. - Tag override_dh_auto_{configure,build,install} rules with -arch, and add no-op -indep variants. - Retire override_dh_installman in favor of debian/goo.manpages, to ensure elpa-goo doesn't try to ship goo.1. - Make override_dh_elpa_test a no-op for now to work around libdebian-source-perl bug #919964.
-rw-r--r--debian/changelog15
-rw-r--r--debian/control6
-rw-r--r--debian/goo.manpages1
-rwxr-xr-xdebian/rules16
4 files changed, 28 insertions, 10 deletions
diff --git a/debian/changelog b/debian/changelog
index 4adfc0d..7576cae 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -22,13 +22,24 @@ goo (0.155-16) UNRELEASED; urgency=medium
- Advance debhelper version requirement to 11~ accordingly.
- Rules-Requires-Root: no (safe with override_dh_auto_install fixed).
- Repoint Vcs-{Browser,Git} at salsa.
+ - Split out Build-Depends-Arch (lib*-dev) and -Indep (dh-elpa).
+ * debian/goo.manpages: New, to avoid needing override_dh_installman.
* debian/rules:
- Run dh --without autoreconf, at least for now.
- override_dh_auto_install: Don't micromanage /usr/bin/goo's ownership
or permissions; they both come out correct by default, and trying to
specify ownership explicitly fails without (fake)root.
-
- -- Aaron M. Ucko <ucko@debian.org> Sun, 20 Jan 2019 18:52:14 -0500
+ - Streamline builds that cover only architecture-dependent or
+ -independent binary packages.
+ + Limit use of --with elpa to binary and binary-indep.
+ + Tag override_dh_auto_{configure,build,install} rules with -arch,
+ and add no-op -indep variants.
+ + Retire override_dh_installman in favor of debian/goo.manpages,
+ to ensure elpa-goo doesn't try to ship goo.1.
+ + Make override_dh_elpa_test a no-op for now to work around
+ libdebian-source-perl bug #919964.
+
+ -- Aaron M. Ucko <ucko@debian.org> Sun, 20 Jan 2019 22:21:27 -0500
goo (0.155-15) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index 2164987..53f80e4 100644
--- a/debian/control
+++ b/debian/control
@@ -3,9 +3,9 @@ Maintainer: Aaron M. Ucko <ucko@debian.org>
Section: lisp
Priority: optional
Build-Depends: debhelper (>= 11~),
- dh-elpa,
- libgc-dev,
- libgmp10-dev | libgmp-dev
+Build-Depends-Arch: libgc-dev,
+ libgmp10-dev | libgmp-dev
+Build-Depends-Indep: dh-elpa
Standards-Version: 3.9.8
Vcs-Browser: https://salsa.debian.org/ucko/goo
Vcs-Git: https://salsa.debian.org/ucko/goo.git
diff --git a/debian/goo.manpages b/debian/goo.manpages
new file mode 100644
index 0000000..0124aa8
--- /dev/null
+++ b/debian/goo.manpages
@@ -0,0 +1 @@
+debian/goo.1
diff --git a/debian/rules b/debian/rules
index 29b5d40..62d01bc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,12 +16,17 @@ endif
export CFLAGS LDFLAGS
%:
+ dh $@ --without autoreconf
+
+binary binary-indep:
dh $@ --with elpa --without autoreconf
-override_dh_auto_configure:
+override_dh_auto_configure-indep:;
+override_dh_auto_configure-arch:
dh_auto_configure -- --with-threads
-override_dh_auto_build:
+override_dh_auto_build-indep:;
+override_dh_auto_build-arch:
# We need to be strict about requiring prototypes because many functions
# return pointers, and their results may otherwise be misinterpreted on
# 64-bit systems. However, this flag inconveniently manages to make a
@@ -29,7 +34,8 @@ override_dh_auto_build:
# only when actually building.
dh_auto_build -- CFLAGS="$(CFLAGS) -Werror-implicit-function-declaration"
-override_dh_auto_install:
+override_dh_auto_install-indep:;
+override_dh_auto_install-arch:
# No support for DESTDIR yet :-/
dh_auto_install -- prefix=$(CURDIR)/debian/goo/usr
mv debian/goo/usr/bin/goo debian/goo/usr/bin/g2c
@@ -41,5 +47,5 @@ override_dh_installdocs:
override_dh_installchangelogs:
dh_installchangelogs txt/changes.txt
-override_dh_installman:
- dh_installman debian/goo.1
+# Work around libdebian-source-perl bug #919964 (lack of B-D-Arch support).
+override_dh_elpa_test:;