summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAlessio Treglia <alessio@debian.org>2012-11-16 12:06:41 +0000
committerAlessio Treglia <alessio@debian.org>2012-11-16 12:06:41 +0000
commite8092b7c334ccc3e3fb9a0bbc2ef7b4c249b9aa3 (patch)
treeac35ec8ebc24b486ae87f7f37bfd2f487567a8c9 /Makefile
parent18c758e5c75b25c9c159e9247820375b5178783a (diff)
Imported Upstream version 0.5.0+svn4231~dfsg0
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 13b2533..a3bd4b4 100644
--- a/Makefile
+++ b/Makefile
@@ -11,7 +11,7 @@ all: version
$(MAKE) -C modules all
version:
- @if [ -d ".svn" ]; then if which svnversion >/dev/null; then echo "#define GPAC_SVN_REVISION \"$(shell svnversion $(SRC_PATH) )\"" > $(SRC_PATH)/include/gpac/version.h ; else echo "No SVN Version found"; fi; fi
+ @if [ -d ".svn" ]; then if which svnversion >/dev/null; then echo "#define GPAC_SVN_REVISION \"$(shell svnversion $(SRC_PATH) )\"" > $(SRC_PATH)/include/gpac/revision.h ; else echo "No SVN Version found"; fi; fi
lib: version
$(MAKE) -C src all
@@ -47,7 +47,7 @@ distclean:
dep: depend
# tar release (use 'make -k tar' on a checkouted tree)
-FILE=gpac-$(shell grep "\#define GPAC_VERSION " include/gpac/tools.h | \
+FILE=gpac-$(shell grep "\#define GPAC_VERSION " include/gpac/version.h | \
cut -d "\"" -f 2 )
tar:
@@ -160,8 +160,9 @@ deb:
sed -i "s/.DEV/.DEV-r`svnversion \"$(SRC_PATH)\"`/" debian/changelog
fakeroot debian/rules configure
fakeroot debian/rules binary
+ rm -rf debian/
svn cleanup
- svn revert debian/changelog
+ svn up
endif
help:
@@ -184,7 +185,7 @@ ifeq ($(CONFIG_DARWIN),yes)
@echo "dmg: creates DMG package file for OSX"
endif
ifeq ($(CONFIG_LINUX),yes)
- @echo "dmg: creates DEB package file for debian based systems"
+ @echo "deb: creates DEB package file for debian based systems"
endif
@echo
@echo "install-lib: install gpac library (dyn and static) and headers <gpac/*.h>, <gpac/modules/*.h> and <gpac/internal/*.h>"