summaryrefslogtreecommitdiff
path: root/configure
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2017-06-19 08:38:07 +0200
committerDidier Raboud <odyx@debian.org>2017-06-19 08:38:07 +0200
commitaedf3e93e811c6c9d504274172861d266e1c5c97 (patch)
tree95e525108c5b6bd2ea3fa689cf11bfe4a5b982a9 /configure
parent7bd83d89975d166521a0b326b64b4cad80117750 (diff)
New upstream version 5.2.13~pre1
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure319
1 files changed, 256 insertions, 63 deletions
diff --git a/configure b/configure
index 6703643..e504828 100755
--- a/configure
+++ b/configure
@@ -1,7 +1,7 @@
#! /bin/sh
# From configure.ac Revision.
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for gutenprint 5.2.12.
+# Generated by GNU Autoconf 2.69 for gutenprint 5.2.13-pre1.
#
# Report bugs to <gimp-print-devel@lists.sourceforge.net>.
#
@@ -608,8 +608,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='gutenprint'
PACKAGE_TARNAME='gutenprint'
-PACKAGE_VERSION='5.2.12'
-PACKAGE_STRING='gutenprint 5.2.12'
+PACKAGE_VERSION='5.2.13-pre1'
+PACKAGE_STRING='gutenprint 5.2.13-pre1'
PACKAGE_BUGREPORT='gimp-print-devel@lists.sourceforge.net'
PACKAGE_URL=''
@@ -656,6 +656,7 @@ am__EXEEXT_FALSE
am__EXEEXT_TRUE
LTLIBOBJS
LIBOBJS
+PKGROOT
LIBUSB_BACKEND_LIBDEPS
GUTENPRINT_RELEASE_VERSION
GUTENPRINT_BASE_VERSION
@@ -734,6 +735,13 @@ BUILD_CUPS_FALSE
BUILD_CUPS_TRUE
GNUCFLAGS
DIALOG
+CSUF
+COMPRESS
+RZIP
+LRZIP
+BZIP2
+GZIP
+XZ
DOXYGEN
DB2HTML
DB2PS
@@ -747,7 +755,6 @@ PERL
FIND
TRUE
TEST
-BZIP2
YFLAGS
YACC
LEXLIB
@@ -1513,7 +1520,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures gutenprint 5.2.12 to adapt to many kinds of systems.
+\`configure' configures gutenprint 5.2.13-pre1 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1583,7 +1590,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of gutenprint 5.2.12:";;
+ short | recursive ) echo "Configuration of gutenprint 5.2.13-pre1:";;
esac
cat <<\_ACEOF
@@ -1761,7 +1768,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-gutenprint configure 5.2.12
+gutenprint configure 5.2.13-pre1
generated by GNU Autoconf 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
@@ -2201,7 +2208,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by gutenprint $as_me 5.2.12, which was
+It was created by gutenprint $as_me 5.2.13-pre1, which was
generated by GNU Autoconf 2.69. Invocation command line was
$ $0 $@
@@ -2588,12 +2595,12 @@ ac_configure="$SHELL $ac_aux_dir/configure" # Please don't use this var.
GUTENPRINT_MAJOR_VERSION=5
GUTENPRINT_MINOR_VERSION=2
-GUTENPRINT_MICRO_VERSION=12
-GUTENPRINT_EXTRA_VERSION=
-GUTENPRINT_CURRENT_INTERFACE=7
+GUTENPRINT_MICRO_VERSION=13
+GUTENPRINT_EXTRA_VERSION=-pre1
+GUTENPRINT_CURRENT_INTERFACE=8
GUTENPRINT_INTERFACE_AGE=0
-GUTENPRINT_BINARY_AGE=5
-GUTENPRINT_VERSION=5.2.12
+GUTENPRINT_BINARY_AGE=6
+GUTENPRINT_VERSION=5.2.13-pre1
GUTENPRINTUI2_CURRENT_INTERFACE=1
GUTENPRINTUI2_INTERFACE_AGE=0
GUTENPRINTUI2_BINARY_AGE=0
@@ -3109,7 +3116,7 @@ fi
# Define the identity of the package.
PACKAGE='gutenprint'
- VERSION='5.2.12'
+ VERSION='5.2.13-pre1'
cat >>confdefs.h <<_ACEOF
@@ -14286,7 +14293,6 @@ fi
# libusb-1.0 (For CUPS backends, but only bother if CUPS is enabled)
-if test "x$BUILD_CUPS" = "xyes" ; then
@@ -14407,6 +14413,8 @@ $as_echo "no" >&6; }
PKG_CONFIG=""
fi
fi
+if test "x$BUILD_CUPS" = "xyes"; then :
+
pkg_failed=no
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for LIBUSB" >&5
@@ -14481,6 +14489,7 @@ $as_echo "yes" >&6; }
HAVE_LIBUSB=yes
BUILD_LIBUSB_BACKENDS=yes
fi
+
fi
if test -n "$ac_tool_prefix"; then
@@ -14677,7 +14686,8 @@ $as_echo "yes" >&6; }
GUTENPRINTUI2_LIBDEPS="${GUTENPRINTUI2_LIBDEPS} ${GTK2_LIBS}"
fi
# Require both gimptool and pkg-config to succeed
-if test x$BUILD_GIMP2 = xyes; then
+if test "x$BUILD_GIMP2" = "xyes"; then :
+
pkg_failed=no
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for GIMP2" >&5
@@ -14749,6 +14759,7 @@ else
$as_echo "yes" >&6; }
BUILD_GIMP2=yes
fi
+
fi
# create custom command-line --with option
@@ -16908,46 +16919,6 @@ done
test -n "$YACC" || YACC="yacc"
-# Extract the first word of "bzip2", so it can be a program name with args.
-set dummy bzip2; ac_word=$2
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
-$as_echo_n "checking for $ac_word... " >&6; }
-if ${ac_cv_path_BZIP2+:} false; then :
- $as_echo_n "(cached) " >&6
-else
- case $BZIP2 in
- [\\/]* | ?:[\\/]*)
- ac_cv_path_BZIP2="$BZIP2" # Let the user override the test with a path.
- ;;
- *)
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-for as_dir in $PATH
-do
- IFS=$as_save_IFS
- test -z "$as_dir" && as_dir=.
- for ac_exec_ext in '' $ac_executable_extensions; do
- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
- ac_cv_path_BZIP2="$as_dir/$ac_word$ac_exec_ext"
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
- break 2
- fi
-done
- done
-IFS=$as_save_IFS
-
- ;;
-esac
-fi
-BZIP2=$ac_cv_path_BZIP2
-if test -n "$BZIP2"; then
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $BZIP2" >&5
-$as_echo "$BZIP2" >&6; }
-else
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; }
-fi
-
-
# Extract the first word of "test", so it can be a program name with args.
set dummy test; ac_word=$2
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
@@ -17522,6 +17493,225 @@ $as_echo "$as_me: WARNING: HTML developer's guide cannot be regenerated!" >&2;}
fi
fi
+# Extract the first word of "xz", so it can be a program name with args.
+set dummy xz; ac_word=$2
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+$as_echo_n "checking for $ac_word... " >&6; }
+if ${ac_cv_path_XZ+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+ case $XZ in
+ [\\/]* | ?:[\\/]*)
+ ac_cv_path_XZ="$XZ" # Let the user override the test with a path.
+ ;;
+ *)
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+for as_dir in $PATH
+do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+ ac_cv_path_XZ="$as_dir/$ac_word$ac_exec_ext"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+ fi
+done
+ done
+IFS=$as_save_IFS
+
+ ;;
+esac
+fi
+XZ=$ac_cv_path_XZ
+if test -n "$XZ"; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $XZ" >&5
+$as_echo "$XZ" >&6; }
+else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+fi
+
+
+# Extract the first word of "gzip", so it can be a program name with args.
+set dummy gzip; ac_word=$2
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+$as_echo_n "checking for $ac_word... " >&6; }
+if ${ac_cv_path_GZIP+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+ case $GZIP in
+ [\\/]* | ?:[\\/]*)
+ ac_cv_path_GZIP="$GZIP" # Let the user override the test with a path.
+ ;;
+ *)
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+for as_dir in $PATH
+do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+ ac_cv_path_GZIP="$as_dir/$ac_word$ac_exec_ext"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+ fi
+done
+ done
+IFS=$as_save_IFS
+
+ ;;
+esac
+fi
+GZIP=$ac_cv_path_GZIP
+if test -n "$GZIP"; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $GZIP" >&5
+$as_echo "$GZIP" >&6; }
+else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+fi
+
+
+# Extract the first word of "bzip2", so it can be a program name with args.
+set dummy bzip2; ac_word=$2
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+$as_echo_n "checking for $ac_word... " >&6; }
+if ${ac_cv_path_BZIP2+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+ case $BZIP2 in
+ [\\/]* | ?:[\\/]*)
+ ac_cv_path_BZIP2="$BZIP2" # Let the user override the test with a path.
+ ;;
+ *)
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+for as_dir in $PATH
+do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+ ac_cv_path_BZIP2="$as_dir/$ac_word$ac_exec_ext"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+ fi
+done
+ done
+IFS=$as_save_IFS
+
+ ;;
+esac
+fi
+BZIP2=$ac_cv_path_BZIP2
+if test -n "$BZIP2"; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $BZIP2" >&5
+$as_echo "$BZIP2" >&6; }
+else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+fi
+
+
+# Extract the first word of "lrzip", so it can be a program name with args.
+set dummy lrzip; ac_word=$2
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+$as_echo_n "checking for $ac_word... " >&6; }
+if ${ac_cv_path_LRZIP+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+ case $LRZIP in
+ [\\/]* | ?:[\\/]*)
+ ac_cv_path_LRZIP="$LRZIP" # Let the user override the test with a path.
+ ;;
+ *)
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+for as_dir in $PATH
+do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+ ac_cv_path_LRZIP="$as_dir/$ac_word$ac_exec_ext"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+ fi
+done
+ done
+IFS=$as_save_IFS
+
+ ;;
+esac
+fi
+LRZIP=$ac_cv_path_LRZIP
+if test -n "$LRZIP"; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $LRZIP" >&5
+$as_echo "$LRZIP" >&6; }
+else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+fi
+
+
+# Extract the first word of "rzip", so it can be a program name with args.
+set dummy rzip; ac_word=$2
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+$as_echo_n "checking for $ac_word... " >&6; }
+if ${ac_cv_path_RZIP+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+ case $RZIP in
+ [\\/]* | ?:[\\/]*)
+ ac_cv_path_RZIP="$RZIP" # Let the user override the test with a path.
+ ;;
+ *)
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+for as_dir in $PATH
+do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+ ac_cv_path_RZIP="$as_dir/$ac_word$ac_exec_ext"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+ fi
+done
+ done
+IFS=$as_save_IFS
+
+ ;;
+esac
+fi
+RZIP=$ac_cv_path_RZIP
+if test -n "$RZIP"; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $RZIP" >&5
+$as_echo "$RZIP" >&6; }
+else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+fi
+
+
+if test x${LRZIP} != x ; then
+ COMPRESS="${LRZIP} -z -q"
+ CSUF=.lrz
+elif test x${XZ} != x ; then
+ COMPRESS="${XZ} -e -9"
+ CSUF=.xz
+elif test x${RZIP} != x ; then
+ COMPRESS="${RZIP} -9"
+ CSUF=.rz
+elif test x${BZIP2} != x ; then
+ COMPRESS="${BZIP2} -9"
+ CSUF=.bz2
+else
+ COMPRESS="${GZIP} -9"
+ CSUF=.gz
+fi
+
+
+
if test x${BUILD_CUPS} = xyes; then
# Extract the first word of "dialog", so it can be a program name with args.
set dummy dialog; ac_word=$2
@@ -19570,7 +19760,7 @@ cat >>confdefs.h <<_ACEOF
#define CUPS_PPD_PS_LEVEL ${CUPS_PPD_PS_LEVEL}
_ACEOF
-RELEASE_DATE="13 Jan 2017"
+RELEASE_DATE="21 May 2017"
cat >>confdefs.h <<_ACEOF
#define RELEASE_DATE "${RELEASE_DATE}"
@@ -19580,6 +19770,8 @@ _ACEOF
RM='rm'
+PKGROOT=`pwd`
+
@@ -19624,6 +19816,7 @@ gutenprintui2_libs="${GUTENPRINTUI2_LIBS} ${gutenprintui2_libdeps}"
+
# Check whether --with-archflags was given.
if test "${with_archflags+set}" = set; then :
withval=$with_archflags; CFLAGS="$CFLAGS $withval"
@@ -19680,8 +19873,6 @@ ac_config_files="$ac_config_files src/testpattern/compare-checksums"
ac_config_files="$ac_config_files src/testpattern/compress-checksums"
-ac_config_files="$ac_config_files src/testpattern/uncompress-checksums"
-
ac_config_files="$ac_config_files src/cups/test-rastertogutenprint"
ac_config_files="$ac_config_files src/testpattern/Makefile"
@@ -19720,6 +19911,8 @@ ac_config_files="$ac_config_files scripts/Makefile"
ac_config_files="$ac_config_files scripts/mkgitlog"
+ac_config_files="$ac_config_files scripts/gversion"
+
ac_config_commands="$ac_config_commands default"
@@ -20352,7 +20545,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by gutenprint $as_me 5.2.12, which was
+This file was extended by gutenprint $as_me 5.2.13-pre1, which was
generated by GNU Autoconf 2.69. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -20418,7 +20611,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-gutenprint config.status 5.2.12
+gutenprint config.status 5.2.13-pre1
configured by $0, generated by GNU Autoconf 2.69,
with options \\"\$ac_cs_config\\"
@@ -20862,7 +21055,6 @@ do
"src/testpattern/run-testpattern-2") CONFIG_FILES="$CONFIG_FILES src/testpattern/run-testpattern-2" ;;
"src/testpattern/compare-checksums") CONFIG_FILES="$CONFIG_FILES src/testpattern/compare-checksums" ;;
"src/testpattern/compress-checksums") CONFIG_FILES="$CONFIG_FILES src/testpattern/compress-checksums" ;;
- "src/testpattern/uncompress-checksums") CONFIG_FILES="$CONFIG_FILES src/testpattern/uncompress-checksums" ;;
"src/cups/test-rastertogutenprint") CONFIG_FILES="$CONFIG_FILES src/cups/test-rastertogutenprint" ;;
"src/testpattern/Makefile") CONFIG_FILES="$CONFIG_FILES src/testpattern/Makefile" ;;
"src/gimp2/Makefile") CONFIG_FILES="$CONFIG_FILES src/gimp2/Makefile" ;;
@@ -20882,6 +21074,7 @@ do
"test/Makefile") CONFIG_FILES="$CONFIG_FILES test/Makefile" ;;
"scripts/Makefile") CONFIG_FILES="$CONFIG_FILES scripts/Makefile" ;;
"scripts/mkgitlog") CONFIG_FILES="$CONFIG_FILES scripts/mkgitlog" ;;
+ "scripts/gversion") CONFIG_FILES="$CONFIG_FILES scripts/gversion" ;;
"default") CONFIG_COMMANDS="$CONFIG_COMMANDS default" ;;
*) as_fn_error $? "invalid argument: \`$ac_config_target'" "$LINENO" 5;;
@@ -22318,9 +22511,9 @@ fi
"src/testpattern/run-testpattern-2":F) chmod +x src/testpattern/run-testpattern-2 ;;
"src/testpattern/compare-checksums":F) chmod +x src/testpattern/compare-checksums ;;
"src/testpattern/compress-checksums":F) chmod +x src/testpattern/compress-checksums ;;
- "src/testpattern/uncompress-checksums":F) chmod +x src/testpattern/uncompress-checksums ;;
"src/cups/test-rastertogutenprint":F) chmod +x src/cups/test-rastertogutenprint ;;
"scripts/mkgitlog":F) chmod +x scripts/mkgitlog ;;
+ "scripts/gversion":F) chmod +x scripts/gversion ;;
"default":C)
echo
;;