summaryrefslogtreecommitdiff
path: root/configure
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2016-10-05 09:16:08 +0200
committerDidier Raboud <odyx@debian.org>2016-10-05 09:16:08 +0200
commitd69d392d8c45cdcc93e58f0e1bdbb2b66d6b9566 (patch)
treefbd96013c3d605249b167a97c8862f38f8a1cdee /configure
parent7f5731038556e5b03d2a886163ca2c873c77333d (diff)
New upstream version 5.2.12~pre3
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure86
1 files changed, 68 insertions, 18 deletions
diff --git a/configure b/configure
index 8d8a273..05372f1 100755
--- a/configure
+++ b/configure
@@ -1,7 +1,7 @@
#! /bin/sh
# From configure.ac Revision.
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for gutenprint 5.2.12-pre2.
+# Generated by GNU Autoconf 2.69 for gutenprint 5.2.12-pre3.
#
# Report bugs to <gimp-print-devel@lists.sourceforge.net>.
#
@@ -608,8 +608,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='gutenprint'
PACKAGE_TARNAME='gutenprint'
-PACKAGE_VERSION='5.2.12-pre2'
-PACKAGE_STRING='gutenprint 5.2.12-pre2'
+PACKAGE_VERSION='5.2.12-pre3'
+PACKAGE_STRING='gutenprint 5.2.12-pre3'
PACKAGE_BUGREPORT='gimp-print-devel@lists.sourceforge.net'
PACKAGE_URL=''
@@ -747,6 +747,7 @@ PERL
FIND
TRUE
TEST
+BZIP2
YFLAGS
YACC
LEXLIB
@@ -1512,7 +1513,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures gutenprint 5.2.12-pre2 to adapt to many kinds of systems.
+\`configure' configures gutenprint 5.2.12-pre3 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1582,7 +1583,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of gutenprint 5.2.12-pre2:";;
+ short | recursive ) echo "Configuration of gutenprint 5.2.12-pre3:";;
esac
cat <<\_ACEOF
@@ -1760,7 +1761,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-gutenprint configure 5.2.12-pre2
+gutenprint configure 5.2.12-pre3
generated by GNU Autoconf 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
@@ -2200,7 +2201,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by gutenprint $as_me 5.2.12-pre2, which was
+It was created by gutenprint $as_me 5.2.12-pre3, which was
generated by GNU Autoconf 2.69. Invocation command line was
$ $0 $@
@@ -2588,11 +2589,11 @@ ac_configure="$SHELL $ac_aux_dir/configure" # Please don't use this var.
GUTENPRINT_MAJOR_VERSION=5
GUTENPRINT_MINOR_VERSION=2
GUTENPRINT_MICRO_VERSION=12
-GUTENPRINT_EXTRA_VERSION=-pre2
-GUTENPRINT_CURRENT_INTERFACE=6
+GUTENPRINT_EXTRA_VERSION=-pre3
+GUTENPRINT_CURRENT_INTERFACE=7
GUTENPRINT_INTERFACE_AGE=0
-GUTENPRINT_BINARY_AGE=4
-GUTENPRINT_VERSION=5.2.12-pre2
+GUTENPRINT_BINARY_AGE=5
+GUTENPRINT_VERSION=5.2.12-pre3
GUTENPRINTUI2_CURRENT_INTERFACE=1
GUTENPRINTUI2_INTERFACE_AGE=0
GUTENPRINTUI2_BINARY_AGE=0
@@ -3108,7 +3109,7 @@ fi
# Define the identity of the package.
PACKAGE='gutenprint'
- VERSION='5.2.12-pre2'
+ VERSION='5.2.12-pre3'
cat >>confdefs.h <<_ACEOF
@@ -16906,6 +16907,47 @@ fi
done
test -n "$YACC" || YACC="yacc"
+
+# Extract the first word of "bzip2", so it can be a program name with args.
+set dummy bzip2; ac_word=$2
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+$as_echo_n "checking for $ac_word... " >&6; }
+if ${ac_cv_path_BZIP2+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+ case $BZIP2 in
+ [\\/]* | ?:[\\/]*)
+ ac_cv_path_BZIP2="$BZIP2" # Let the user override the test with a path.
+ ;;
+ *)
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+for as_dir in $PATH
+do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+ ac_cv_path_BZIP2="$as_dir/$ac_word$ac_exec_ext"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+ fi
+done
+ done
+IFS=$as_save_IFS
+
+ ;;
+esac
+fi
+BZIP2=$ac_cv_path_BZIP2
+if test -n "$BZIP2"; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $BZIP2" >&5
+$as_echo "$BZIP2" >&6; }
+else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+fi
+
+
# Extract the first word of "test", so it can be a program name with args.
set dummy test; ac_word=$2
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
@@ -17646,7 +17688,7 @@ rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
if test x${USE_MAINTAINER_MODE} = xyes ; then
- for stp_ac_arg in -pedantic -Waggregate-return -Wcast-qual -Wshadow -Wredundant-decls ; do
+ for stp_ac_arg in -D_POSIX_C_SOURCE=200809L -std=c99 -pedantic -Waggregate-return -Wcast-qual -Wshadow -Wredundant-decls ; do
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking if ${CC} supports ${stp_ac_arg}" >&5
$as_echo_n "checking if ${CC} supports ${stp_ac_arg}... " >&6; }
@@ -19430,7 +19472,7 @@ fi
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking which module system will be used" >&5
$as_echo_n "checking which module system will be used... " >&6; }
if test x$USE_LTDL = xtrue; then
- if test -n "$WITH_MODULES" ; then
+ if test -z "$WITH_MODULES" -o x$WITH_MODULES = xno -o x$WITH_MODULES = xstatic ; then
MODULE="false"
else
MODULE="true"
@@ -19447,7 +19489,7 @@ $as_echo "#define USE_LTDL \"1\"" >>confdefs.h
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: ltdl" >&5
$as_echo "ltdl" >&6; }
elif test x$USE_DLOPEN = xtrue; then
- if test -n "$WITH_MODULES" ; then
+ if test -z "$WITH_MODULES" -o x$WITH_MODULES = xno -o x$WITH_MODULES = xstatic ; then
MODULE="false"
else
MODULE="true"
@@ -19528,7 +19570,7 @@ cat >>confdefs.h <<_ACEOF
#define CUPS_PPD_PS_LEVEL ${CUPS_PPD_PS_LEVEL}
_ACEOF
-RELEASE_DATE="19 Sep 2016"
+RELEASE_DATE="01 Oct 2016"
cat >>confdefs.h <<_ACEOF
#define RELEASE_DATE "${RELEASE_DATE}"
@@ -19636,6 +19678,10 @@ ac_config_files="$ac_config_files src/testpattern/run-testpattern-2"
ac_config_files="$ac_config_files src/testpattern/compare-checksums"
+ac_config_files="$ac_config_files src/testpattern/compress-checksums"
+
+ac_config_files="$ac_config_files src/testpattern/uncompress-checksums"
+
ac_config_files="$ac_config_files src/cups/test-rastertogutenprint"
ac_config_files="$ac_config_files src/testpattern/Makefile"
@@ -20306,7 +20352,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by gutenprint $as_me 5.2.12-pre2, which was
+This file was extended by gutenprint $as_me 5.2.12-pre3, which was
generated by GNU Autoconf 2.69. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -20372,7 +20418,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-gutenprint config.status 5.2.12-pre2
+gutenprint config.status 5.2.12-pre3
configured by $0, generated by GNU Autoconf 2.69,
with options \\"\$ac_cs_config\\"
@@ -20815,6 +20861,8 @@ do
"src/escputil/Makefile") CONFIG_FILES="$CONFIG_FILES src/escputil/Makefile" ;;
"src/testpattern/run-testpattern-2") CONFIG_FILES="$CONFIG_FILES src/testpattern/run-testpattern-2" ;;
"src/testpattern/compare-checksums") CONFIG_FILES="$CONFIG_FILES src/testpattern/compare-checksums" ;;
+ "src/testpattern/compress-checksums") CONFIG_FILES="$CONFIG_FILES src/testpattern/compress-checksums" ;;
+ "src/testpattern/uncompress-checksums") CONFIG_FILES="$CONFIG_FILES src/testpattern/uncompress-checksums" ;;
"src/cups/test-rastertogutenprint") CONFIG_FILES="$CONFIG_FILES src/cups/test-rastertogutenprint" ;;
"src/testpattern/Makefile") CONFIG_FILES="$CONFIG_FILES src/testpattern/Makefile" ;;
"src/gimp2/Makefile") CONFIG_FILES="$CONFIG_FILES src/gimp2/Makefile" ;;
@@ -22269,6 +22317,8 @@ fi
"src/cups/cups-genppdupdate":F) chmod +x src/cups/cups-genppdupdate ;;
"src/testpattern/run-testpattern-2":F) chmod +x src/testpattern/run-testpattern-2 ;;
"src/testpattern/compare-checksums":F) chmod +x src/testpattern/compare-checksums ;;
+ "src/testpattern/compress-checksums":F) chmod +x src/testpattern/compress-checksums ;;
+ "src/testpattern/uncompress-checksums":F) chmod +x src/testpattern/uncompress-checksums ;;
"src/cups/test-rastertogutenprint":F) chmod +x src/cups/test-rastertogutenprint ;;
"scripts/mkgitlog":F) chmod +x scripts/mkgitlog ;;
"default":C)