summaryrefslogtreecommitdiff
path: root/src/xml/Makefile.am
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2008-10-26 17:28:54 +0000
committerRoger Leigh <rleigh@debian.org>2008-10-26 17:28:54 +0000
commit33a17feb28af2d2aeabc8c7ab5ef509ea3de15a7 (patch)
treed444cf1a245694bd049a9e6722c41b8f280ad429 /src/xml/Makefile.am
parent9d82a443d65ea3e4e015ba6988208231fa8fdc77 (diff)
Imported Upstream version 5.2.1
Diffstat (limited to 'src/xml/Makefile.am')
-rw-r--r--src/xml/Makefile.am66
1 files changed, 66 insertions, 0 deletions
diff --git a/src/xml/Makefile.am b/src/xml/Makefile.am
new file mode 100644
index 0000000..65d76f5
--- /dev/null
+++ b/src/xml/Makefile.am
@@ -0,0 +1,66 @@
+## $Id: Makefile.am,v 1.2 2008/06/10 13:10:22 rlk Exp $
+## Copyright (C) 2008 Robert Krawitz
+##
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 2, or (at your option)
+## any later version.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+## Process this file with automake to produce Makefile.in.
+
+@SET_MAKE@
+
+include $(top_srcdir)/scripts/global.mk
+
+SUBDIRS = escp2
+
+## Variables
+
+pkgxmldatadir = $(pkgdatadir)/@GUTENPRINT_MAJOR_VERSION@.@GUTENPRINT_MINOR_VERSION@/xml
+
+pkgxmldata_DATA = \
+ dither-matrix-1x1.xml \
+ dither-matrix-2x1.xml \
+ dither-matrix-4x1.xml \
+ papers.xml \
+ printers.xml
+
+## Rules
+
+noinst_PROGRAMS = extract-strings
+
+extract_strings_SOURCES = extract-strings.c
+extract_strings_LDADD = $(GUTENPRINT_LIBS)
+
+xml-stamp: $(pkgxmldata_DATA) escp2/xml-stamp Makefile.am
+ -rm -f xml-stamp
+ touch xml-stamp
+ sed 's;^;escp2/;' escp2/xml-stamp >> xml-stamp
+ for f in $(pkgxmldata_DATA) ; do echo $$f >> xml-stamp; done
+
+all-local: xmli18n-tmp.h xml-stamp
+
+
+xmli18n-tmp.h: xml-stamp extract-strings
+ ./extract-strings `cat xml-stamp` > xmli18n-tmp.h
+
+
+dist-hook: xmli18n-tmp.h
+# xmli18n-tmp.h is needed by po/POTFILES.in at dist time
+
+## Clean
+
+CLEANFILES = xmli18n-tmp.h xml-stamp
+
+EXTRA_DIST = $(pkgxmldata_DATA)
+
+MAINTAINERCLEANFILES = Makefile.in