summaryrefslogtreecommitdiff
path: root/samples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'samples/Makefile.am')
-rw-r--r--samples/Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/samples/Makefile.am b/samples/Makefile.am
index 007a61c..058f220 100644
--- a/samples/Makefile.am
+++ b/samples/Makefile.am
@@ -1,4 +1,4 @@
-## $Id: Makefile.am,v 1.3 2001/09/18 18:03:57 rleigh Exp $
+## $Id: Makefile.am,v 1.5 2003/01/01 21:06:03 rleigh Exp $
## Copyright (C) 2000 Roger Leigh
##
## This program is free software; you can redistribute it and/or modify
@@ -23,21 +23,23 @@ AUTOMAKE_OPTIONS = 1.4 gnu
MAINT_CHARSET = latin1
+include $(top_srcdir)/scripts/global.mk
-## Variables
-SAMPLE_IMAGES = colorbars4.png colorsweep.png profile.jpg
+## Variables
-pkgdatadir = $(datadir)/$(PACKAGE)/samples
+pkgsampledatadir = $(datadir)/$(PACKAGE)/samples
## Data
-pkgdata_DATA = @SAMPLE_IMAGES@
+if INSTALL_SAMPLES
+pkgsampledata_DATA = colorbars4.png colorsweep.png profile.jpg
+endif
## Clean
MAINTAINERCLEANFILES = Makefile.in
-EXTRA_DIST = $(SAMPLE_IMAGES)
+EXTRA_DIST = $(pkgsampledata_DATA)