summaryrefslogtreecommitdiff
path: root/src/xml/escp2/qualitypresets
diff options
context:
space:
mode:
Diffstat (limited to 'src/xml/escp2/qualitypresets')
-rw-r--r--src/xml/escp2/qualitypresets/Makefile.am11
-rw-r--r--src/xml/escp2/qualitypresets/Makefile.in9
2 files changed, 11 insertions, 9 deletions
diff --git a/src/xml/escp2/qualitypresets/Makefile.am b/src/xml/escp2/qualitypresets/Makefile.am
index 50ba65a..3c73802 100644
--- a/src/xml/escp2/qualitypresets/Makefile.am
+++ b/src/xml/escp2/qualitypresets/Makefile.am
@@ -1,4 +1,4 @@
-## $Id: Makefile.am,v 1.2 2008/10/19 13:57:27 rlk Exp $
+## $Id: Makefile.am,v 1.3 2008/10/24 00:37:14 rleigh Exp $
## Copyright (C) 2008 Robert Krawitz
##
## This program is free software; you can redistribute it and/or modify
@@ -33,12 +33,13 @@ pkgxmldata_DATA = \
wf40.xml
xml-stamp: $(pkgxmldata_DATA) Makefile.am
- -rm -f xml-stamp
- touch xml-stamp
- for f in $(pkgxmldata_DATA) ; do echo $$f >> xml-stamp; done
+ -rm -f $@ $@.tmp
+ touch $@.tmp
+ for f in $(pkgxmldata_DATA) ; do echo $$f >> $@.tmp; done
+ mv $@.tmp $@
all-local: xml-stamp
-CLEANFILES = xmli18n-tmp.h xml-stamp
+CLEANFILES = xmli18n-tmp.h xml-stamp xml-stamp.tmp
EXTRA_DIST = $(pkgxmldata_DATA)
diff --git a/src/xml/escp2/qualitypresets/Makefile.in b/src/xml/escp2/qualitypresets/Makefile.in
index 88ed90f..79a910a 100644
--- a/src/xml/escp2/qualitypresets/Makefile.in
+++ b/src/xml/escp2/qualitypresets/Makefile.in
@@ -280,7 +280,7 @@ pkgxmldata_DATA = \
v2880.xml \
wf40.xml
-CLEANFILES = xmli18n-tmp.h xml-stamp
+CLEANFILES = xmli18n-tmp.h xml-stamp xml-stamp.tmp
EXTRA_DIST = $(pkgxmldata_DATA)
all: all-am
@@ -488,9 +488,10 @@ $(top_builddir)/src/gutenprintui2/libgutenprintui2.la:
$(MAKE)
xml-stamp: $(pkgxmldata_DATA) Makefile.am
- -rm -f xml-stamp
- touch xml-stamp
- for f in $(pkgxmldata_DATA) ; do echo $$f >> xml-stamp; done
+ -rm -f $@ $@.tmp
+ touch $@.tmp
+ for f in $(pkgxmldata_DATA) ; do echo $$f >> $@.tmp; done
+ mv $@.tmp $@
all-local: xml-stamp
# Tell versions [3.59,3.63) of GNU make to not export all variables.