summaryrefslogtreecommitdiff
path: root/src/xml/escp2/weaves/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/xml/escp2/weaves/Makefile.in')
-rw-r--r--src/xml/escp2/weaves/Makefile.in9
1 files changed, 5 insertions, 4 deletions
diff --git a/src/xml/escp2/weaves/Makefile.in b/src/xml/escp2/weaves/Makefile.in
index 2f5a0c4..86a9dbd 100644
--- a/src/xml/escp2/weaves/Makefile.in
+++ b/src/xml/escp2/weaves/Makefile.in
@@ -279,7 +279,7 @@ pkgxmldata_DATA = \
pro7600.xml \
standard.xml
-CLEANFILES = xmli18n-tmp.h xml-stamp
+CLEANFILES = xmli18n-tmp.h xml-stamp xml-stamp.tmp
EXTRA_DIST = $(pkgxmldata_DATA)
all: all-am
@@ -487,9 +487,10 @@ $(top_builddir)/src/gutenprintui2/libgutenprintui2.la:
$(MAKE)
xml-stamp: $(pkgxmldata_DATA) Makefile.am
- -rm -f xml-stamp
- touch xml-stamp
- for f in $(pkgxmldata_DATA) ; do echo $$f >> xml-stamp; done
+ -rm -f $@ $@.tmp
+ touch $@.tmp
+ for f in $(pkgxmldata_DATA) ; do echo $$f >> $@.tmp; done
+ mv $@.tmp $@
all-local: xml-stamp
# Tell versions [3.59,3.63) of GNU make to not export all variables.