summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViktor Dukhovni <viktor@twosigma.com>2016-12-15 02:43:59 -0500
committerViktor Dukhovni <viktor@twosigma.com>2016-12-15 04:31:49 -0500
commitba50bc2b04afd8ce1a7c6d64370bfea287a45b43 (patch)
treea1f7e4f60899efdb51cb9bf3d0405e54eb248854
parenta9ba3b5f9dcfb9aa38ab2822a0e4d791035b002c (diff)
Fix more doxygen bitrot
-rw-r--r--doc/Makefile.am6
-rw-r--r--doc/doxytmpl.dxy10
-rw-r--r--lib/hx509/keyset.c23
-rw-r--r--lib/krb5/context.c3
-rw-r--r--lib/krb5/warn.c1
-rw-r--r--lib/ntlm/ntlm.c2
6 files changed, 14 insertions, 31 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 764226843..2a77c9636 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -74,7 +74,11 @@ doxyout doxygen: base.dxy hdb.dxy hx509.dxy hcrypto.dxy gssapi.dxy krb5.dxy ntlm
for a in $(PROJECTS) ; do \
echo $$a ; \
doxygen $$a.dxy; \
- (cd $(srcdir)/doxyout && find $$a/man -type f -name _\* | perl -lne unlink && \
+ (cd $(srcdir)/doxyout && \
+ find $$a/man -name '_*' -type f -print | \
+ perl -lne unlink && \
+ find $$a/html -name 'dir_*.html' -type f -print | \
+ perl -lne unlink && \
find $$a/man -type f > $$a/manpages ) ; \
done
diff --git a/doc/doxytmpl.dxy b/doc/doxytmpl.dxy
index 1acc964c5..1faab2f52 100644
--- a/doc/doxytmpl.dxy
+++ b/doc/doxytmpl.dxy
@@ -26,7 +26,6 @@ SHORT_NAMES = NO
JAVADOC_AUTOBRIEF = NO
QT_AUTOBRIEF = NO
MULTILINE_CPP_IS_BRIEF = NO
-DETAILS_AT_TOP = NO
INHERIT_DOCS = YES
SEPARATE_MEMBER_PAGES = NO
TAB_SIZE = 8
@@ -65,7 +64,6 @@ GENERATE_DEPRECATEDLIST= YES
ENABLED_SECTIONS =
MAX_INITIALIZER_LINES = 30
SHOW_USED_FILES = YES
-SHOW_DIRECTORIES = NO
FILE_VERSION_FILTER =
#---------------------------------------------------------------------------
# configuration options related to warning and progress messages
@@ -105,8 +103,7 @@ FILE_PATTERNS = *.c \
*.inc \
*.m \
*.mm \
- *.dox \
- *.py
+ *.dox
RECURSIVE = YES
EXCLUDE =
EXCLUDE_SYMLINKS = NO
@@ -142,7 +139,6 @@ GENERATE_HTML = YES
HTML_OUTPUT = html
HTML_FILE_EXTENSION = .html
HTML_STYLESHEET =
-HTML_ALIGN_MEMBERS = YES
GENERATE_HTMLHELP = NO
HTML_DYNAMIC_SECTIONS = NO
CHM_FILE =
@@ -190,8 +186,6 @@ MAN_LINKS = YES
#---------------------------------------------------------------------------
GENERATE_XML = NO
XML_OUTPUT = xml
-XML_SCHEMA =
-XML_DTD =
XML_PROGRAMLISTING = YES
#---------------------------------------------------------------------------
# configuration options for the AutoGen Definitions output
@@ -227,7 +221,6 @@ EXTERNAL_GROUPS = YES
# Configuration options related to the dot tool
#---------------------------------------------------------------------------
CLASS_DIAGRAMS = NO
-MSCGEN_PATH = /usr/bin
HIDE_UNDOC_RELATIONS = YES
HAVE_DOT = YES
CLASS_GRAPH = YES
@@ -242,7 +235,6 @@ CALLER_GRAPH = NO
GRAPHICAL_HIERARCHY = YES
DIRECTORY_GRAPH = YES
DOT_IMAGE_FORMAT = png
-DOT_PATH = /usr/bin
DOTFILE_DIRS =
DOT_GRAPH_MAX_NODES = 50
MAX_DOT_GRAPH_DEPTH = 1000
diff --git a/lib/hx509/keyset.c b/lib/hx509/keyset.c
index 82edec3d0..ed5b22b98 100644
--- a/lib/hx509/keyset.c
+++ b/lib/hx509/keyset.c
@@ -320,8 +320,8 @@ hx509_certs_end_seq(hx509_context context,
}
/**
- * Iterate over all certificates in a keystore and call an function
- * for each fo them.
+ * Iterate over all certificates in a keystore and call a function
+ * for each of them.
*
* @param context a hx509 context.
* @param certs certificate store to iterate over.
@@ -368,21 +368,6 @@ hx509_certs_iter_f(hx509_context context,
return ret;
}
-/**
- * Iterate over all certificates in a keystore and call an function
- * for each fo them.
- *
- * @param context a hx509 context.
- * @param certs certificate store to iterate over.
- * @param func function to call for each certificate. The function
- * should return non-zero to abort the iteration, that value is passed
- * back to the caller of hx509_certs_iter().
- *
- * @return Returns an hx509 error code.
- *
- * @ingroup hx509_keyset
- */
-
#ifdef __BLOCKS__
static int
@@ -393,8 +378,8 @@ certs_iter(hx509_context context, void *ctx, hx509_cert cert)
}
/**
- * Iterate over all certificates in a keystore and call an block
- * for each fo them.
+ * Iterate over all certificates in a keystore and call a block
+ * for each of them.
*
* @param context a hx509 context.
* @param certs certificate store to iterate over.
diff --git a/lib/krb5/context.c b/lib/krb5/context.c
index c5a9edc66..5660f7f36 100644
--- a/lib/krb5/context.c
+++ b/lib/krb5/context.c
@@ -1053,6 +1053,7 @@ krb5_set_default_in_tkt_etypes(krb5_context context,
* with the KDC, clients and servers.
*
* @param context Kerberos 5 context.
+ * @param pdu_type request type (AS, TGS or none)
* @param etypes Encryption types, array terminated with
* ETYPE_NULL(0), caller should free array with krb5_xfree():
*
@@ -1073,7 +1074,7 @@ krb5_get_default_in_tkt_etypes(krb5_context context,
heim_assert(pdu_type == KRB5_PDU_AS_REQUEST ||
pdu_type == KRB5_PDU_TGS_REQUEST ||
- pdu_type == KRB5_PDU_NONE, "pdu contant not as expected");
+ pdu_type == KRB5_PDU_NONE, "unexpected pdu type");
if (pdu_type == KRB5_PDU_AS_REQUEST && context->as_etypes != NULL)
enctypes = context->as_etypes;
diff --git a/lib/krb5/warn.c b/lib/krb5/warn.c
index 3e29ea82a..a0705b70c 100644
--- a/lib/krb5/warn.c
+++ b/lib/krb5/warn.c
@@ -281,6 +281,7 @@ krb5_vabort(krb5_context context, krb5_error_code code,
* @param context A Kerberos 5 context
* @param code error code of the last error
* @param fmt message to print
+ * @param ... arguments for format string
*
* @ingroup krb5_error
*/
diff --git a/lib/ntlm/ntlm.c b/lib/ntlm/ntlm.c
index 5d39bf2d4..7ec0181ff 100644
--- a/lib/ntlm/ntlm.c
+++ b/lib/ntlm/ntlm.c
@@ -1054,6 +1054,7 @@ out:
*
* @param type3 the ntlm_type3 message to encode.
* @param data is the return buffer with the encoded message, should be
+ * @param[out] mic_offset offset of message integrity code
* freed with heim_ntlm_free_buf().
*
* @return In case of success 0 is return, an errors, a errno in what
@@ -1580,7 +1581,6 @@ heim_ntlm_ts2unixtime(uint64_t t)
* @param username name of the user, as sent in the message, assumed to be in UTF8.
* @param target the name of the target, assumed to be in UTF8.
* @param serverchallenge challenge as sent by the server in the type2 message.
- * @param infotarget infotarget as sent by the server in the type2 message.
* @param ntlmv2 calculated session key
* @param answer ntlm response answer, should be freed with heim_ntlm_free_buf().
*