summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorposativ <info@posativ.org>2012-12-17 00:00:49 +0100
committerposativ <info@posativ.org>2012-12-17 00:06:46 +0100
commit26c74cb5213ea18fca728d250acde184def059c0 (patch)
tree93cbd853a778547a62203c2f692e99c03bce8b2c /Makefile
parent261f2fe18ee397ba9e92f8701e77a31e810ad118 (diff)
admin.js now used isso.js as API
JS is a horrible language. The more you try to modularize and DRY it, the greater the LoC grows...
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 4372158..b7078ec 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
ISSO = "isso/js"
-all: js
+all: admin client
init:
git clone https://github.com/posativ/promisejs.git $(ISSO)/promise.js
@@ -8,7 +8,14 @@ init:
(cd $(ISSO) && ender add promise.js)
rm -rf $(ISSO)/promise.js
-js:
+admin:
+ cat $(ISSO)/ender.js $(ISSO)/isso.js $(ISSO)/utils.js $(ISSO)/admin.js > $(ISSO)/_.js
+ yuicompressor --type js --charset utf-8 $(ISSO)/_.js -o $(ISSO)/interface.js
+
+ rm $(ISSO)/_.js
+
+client:
cat $(ISSO)/ender.js $(ISSO)/isso.js $(ISSO)/utils.js $(ISSO)/client.js > $(ISSO)/_.js
yuicompressor --type js --charset utf-8 $(ISSO)/_.js -o $(ISSO)/embed.js
+
rm $(ISSO)/_.js