summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSteffen Prince <steffen@sprin.io>2015-11-02 09:21:07 -0800
committerSteffen Prince <steffen@sprin.io>2015-11-02 09:21:08 -0800
commit367ee48b76f66c36fb3d7f0e6aa44230ade3af75 (patch)
tree6b11fbfe46851c4d23eb1c42a695346c296eb4ff /setup.py
parent5d21e1b20a95d9744425b41e104a71f446fcc315 (diff)
Pin misaka to 1.x
With the release of misaka 2.0, new users experienced breakage when 2.0 was installed (#208). 2.0 has a slightly different API, and Python 2.6 support in 2.0 is not yet released. #212 contains the update to 2.0, so this change should only be a stopgap until the next misaka release with Py2.6 support.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 66eeedd..14a2f77 100644
--- a/setup.py
+++ b/setup.py
@@ -5,7 +5,7 @@ import sys
from setuptools import setup, find_packages
-requires = ['itsdangerous', 'misaka', 'html5lib<0.9999']
+requires = ['itsdangerous', 'misaka>=1.0,<2.0', 'html5lib<0.9999']
if (3, 0) <= sys.version_info < (3, 3):
raise SystemExit("Python 3.0, 3.1 and 3.2 are not supported")