summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMartin Zimmermann <info@posativ.org>2016-02-06 16:20:05 +0100
committerMartin Zimmermann <info@posativ.org>2016-02-06 16:20:07 +0100
commit9496d7d4c2115c0b99f99b971ee29f99e77f1182 (patch)
tree7da87f162992a475446d6acd6fea5ba295201673 /setup.py
parent1401132c7364a51d13c01b0a3ee01e06b539437b (diff)
use environment markers as defined by PEP 426
This is a quote from http://wheel.readthedocs.org/en/latest/. I have no idea what I'm doing. Tested the universal wheel on Python 2.6, 2.7 and 3.4 with pip 7.1. I have no idea what happens with older versions of pip. There is absolutely no documentation. Typical python packaging experience.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 7 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 1e5a48f..38c70c6 100644
--- a/setup.py
+++ b/setup.py
@@ -10,11 +10,6 @@ requires = ['itsdangerous', 'misaka>=1.0,<2.0', 'html5lib==0.9999999']
if (3, 0) <= sys.version_info < (3, 3):
raise SystemExit("Python 3.0, 3.1 and 3.2 are not supported")
-if sys.version_info < (3, 0):
- requires += ['ipaddr>=2.1', 'configparser', 'werkzeug>=0.8']
-else:
- requires += ['werkzeug>=0.9']
-
setup(
name='isso',
version='0.10.dev0',
@@ -34,9 +29,15 @@ setup(
"License :: OSI Approved :: MIT License",
"Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
- "Programming Language :: Python :: 3.3"
+ "Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: 3.4"
],
install_requires=requires,
+ extras_require={
+ ':python_version=="2.6"': ['argparse', 'ordereddict'],
+ ':python_version<="2.7"': ['ipaddr>=2.1', 'configparser', 'werkzeug>=0.8'],
+ ':python_version>="3.0"': ['werkzeug>=0.9']
+ },
entry_points={
'console_scripts':
['isso = isso:main'],