summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuss Allbery <eagle@eyrie.org>2014-02-09 19:22:23 -0800
committerRuss Allbery <eagle@eyrie.org>2014-02-09 19:22:23 -0800
commit314796fa94e64a85274d24f4990dd1061cab5e65 (patch)
tree7a474c61c54b55c2589230b2bb6a5ea5f05678e1
parent782a8f576881db6766e2c34a152eb3c477ff521f (diff)
Further expand the tools/backend test timing range
* The change in 3.0-3 fixed the test suite failure on all architectures except armel, which appears to still be failing with a variation on the original issue. Further expand the valid timing range on the test, since this seems to be on the right track but just didn't go far enough.
-rw-r--r--debian/changelog10
-rwxr-xr-xtests/tools/backend-t2
2 files changed, 11 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index bd46f11..0b4743a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+krb5-sync (3.0-3) unstable; urgency=medium
+
+ * The change in 3.0-3 fixed the test suite failure on all architectures
+ except armel, which appears to still be failing with a variation on
+ the original issue. Further expand the valid timing range on the
+ test, since this seems to be on the right track but just didn't go far
+ enough.
+
+ -- Russ Allbery <rra@debian.org> Sun, 09 Feb 2014 19:21:52 -0800
+
krb5-sync (3.0-2) unstable; urgency=medium
* Fix the tools/backend test suite to be less sensitive to timing when
diff --git a/tests/tools/backend-t b/tests/tools/backend-t
index 146e2f8..3da82cc 100755
--- a/tests/tools/backend-t
+++ b/tests/tools/backend-t
@@ -109,7 +109,7 @@ sub check_queued_action {
# with the same timestamp with a non-zero sequence number.
my $now = time;
my $path;
- for my $time ($now - 5 .. $now) {
+ for my $time ($now - 10 .. $now + 1) {
my $candidate = $base . strftime('%Y%m%dT%H%M%SZ-00', gmtime($time));
if (-f $candidate) {
$path = $candidate;