summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Haber <mh+debian-packages@zugschlus.de>2023-12-09 22:41:53 +0100
committergregor herrmann <gregoa@debian.org>2023-12-09 22:41:53 +0100
commitcc430d912830c428769c7a67ea084884543d175d (patch)
tree2c29b3faa572dceba8998acc415541716978ce79
parentd1e7c8de8353b1e15a5ee5c137c2a8bedec8bfd3 (diff)
This patch removes the -m32 options that the build process
Bug: https://github.com/jacquesg/p5-Git-Raw/issues/199 Reviewed-by: gregor herrmann <gregoa@debian.org> Last-Update: 2022-10-29 adds to 64 bit non-arm builds. This option is not present in most of Debian's 32 bit arches and makes the build fail there, and it is not needed on Debian's 64 bit arches. Gbp-Pq: Name remove-m32
-rw-r--r--Makefile.PL5
-rw-r--r--inc/MakeMaker.pm5
2 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 49bdf741..eb6d3ad3 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -216,7 +216,10 @@ if ($is_gcc) {
# building with a 32-bit perl on a 64-bit OS may require this (supported by cc and gcc-like compilers,
# excluding some ARM toolchains)
if ($Config{ptrsize} == 4 && $Config{archname} !~ /arm/) {
- $ccflags .= ' -m32';
+ # ccflags.='-m32' removed since Debian does not need
+ # this on 64 bit arches, and the presence of the option
+ # makes the build fail on 32 bit arches
+ $ccflags .= '';
}
} elsif ($is_sunpro) {
# probably the SunPro compiler, (try to) enable C99 support
diff --git a/inc/MakeMaker.pm b/inc/MakeMaker.pm
index a4eaf210..6b4ab7fc 100644
--- a/inc/MakeMaker.pm
+++ b/inc/MakeMaker.pm
@@ -229,7 +229,10 @@ if ($is_gcc) {
# building with a 32-bit perl on a 64-bit OS may require this (supported by cc and gcc-like compilers,
# excluding some ARM toolchains)
if ($Config{ptrsize} == 4 && $Config{archname} !~ /arm/) {
- $ccflags .= ' -m32';
+ # ccflags.='-m32' removed since Debian does not need
+ # this on 64 bit arches, and the presence of the option
+ # makes the build fail on 32 bit arches
+ $ccflags .= '';
}
} elsif ($is_sunpro) {
# probably the SunPro compiler, (try to) enable C99 support