summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAndrew O. Shadoura <bugzilla@tut.by>2011-03-19 23:29:03 +0200
committerAndrew O. Shadoura <bugzilla@tut.by>2011-03-19 23:29:03 +0200
commitf798da83ebc1c13d1a60b9a6abadbae878e70457 (patch)
tree6368af5852c69b1aa2aeae718f8a5f8ce7077767 /debian
parent8b09fa80e3920cbd3bb2e39aa86c0fc9b40183e5 (diff)
fix the symbols
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/04-hide-symbols.diff185
1 files changed, 22 insertions, 163 deletions
diff --git a/debian/patches/04-hide-symbols.diff b/debian/patches/04-hide-symbols.diff
index 2c1d227..15cd75b 100644
--- a/debian/patches/04-hide-symbols.diff
+++ b/debian/patches/04-hide-symbols.diff
@@ -2,173 +2,32 @@ Description: Hide symbols internal symbols
Author: Andrew O. Shadoura <bugzilla@tut.by>
Bug: http://jira.atheme.org/browse/LG-4
---- a/src/libguess/dfa.c
-+++ b/src/libguess/dfa.c
-@@ -1,7 +1,7 @@
- #include "libguess.h"
- #include "dfa.h"
+--- a/src/libguess/Makefile
++++ b/src/libguess/Makefile
+@@ -13,5 +13,5 @@
+ include ../../extra.mk
--boolean
-+boolean __attribute__ ((visibility ("hidden")))
- dfa_alone(guess_dfa *dfa, guess_dfa *order[])
- {
- int i;
-@@ -18,7 +18,7 @@
- return TRUE;
- }
+ CPPFLAGS += ${LIB_CPPFLAGS} ${MOWGLI_CFLAGS} -I. -I.. -DLIBGUESS_CORE
+-CFLAGS += ${LIB_CFLAGS}
++CFLAGS += ${LIB_CFLAGS} -fvisibility=hidden
+ LIBS += ${MOWGLI_LIBS}
+--- a/src/libguess/libguess.h
++++ b/src/libguess/libguess.h
+@@ -63,7 +63,7 @@
--boolean
-+boolean __attribute__ ((visibility ("hidden")))
- dfa_none(guess_dfa *order[])
- {
- int i;
-@@ -32,7 +32,7 @@
- return TRUE;
- }
+ #endif
--guess_dfa *
-+guess_dfa * __attribute__ ((visibility ("hidden")))
- dfa_top(guess_dfa *order[])
- {
- int i;
-@@ -46,7 +46,7 @@
- return top;
- }
+-int libguess_validate_utf8(const char *buf, int buflen);
++__attribute__ ((visibility ("default"))) int libguess_validate_utf8(const char *buf, int buflen);
--const char *
-+const char * __attribute__ ((visibility ("hidden")))
- dfa_process(guess_dfa *order[], int c)
- {
- int i;
-diff --git a/src/libguess/guess.c b/src/libguess/guess.c
---- a/src/libguess/guess.c
-+++ b/src/libguess/guess.c
-@@ -2,7 +2,7 @@
+ #define GUESS_REGION_JP "japanese"
+ #define GUESS_REGION_TW "taiwanese"
+@@ -79,6 +79,6 @@
- mowgli_patricia_t *guess_impl_list = NULL;
+ typedef void (*libguess_result_f)(const char *encodingname, const char *res);
--void strcasecanon(char *str)
-+void __attribute__ ((visibility ("hidden"))) strcasecanon(char *str)
- {
- while (*str)
- {
-@@ -11,7 +11,7 @@
- }
- }
+-const char *libguess_determine_encoding(const char *buf, int buflen, const char *langset);
++__attribute__ ((visibility ("default"))) const char *libguess_determine_encoding(const char *buf, int buflen, const char *langset);
--static void
-+static void __attribute__ ((visibility ("hidden")))
- guess_impl_register(const char *lang, guess_impl_f impl)
- {
- return_if_fail(guess_impl_list != NULL);
-@@ -19,7 +19,7 @@
- mowgli_patricia_add(guess_impl_list, lang, impl);
- }
-
--static void
-+static void __attribute__ ((visibility ("hidden")))
- guess_init(void)
- {
- mowgli_init();
-diff --git a/src/libguess/guess_impl.c b/src/libguess/guess_impl.c
---- a/src/libguess/guess_impl.c
-+++ b/src/libguess/guess_impl.c
-@@ -81,7 +81,7 @@
- return 0;
- }
-
--const char *guess_jp(const char *buf, int buflen)
-+const char * __attribute__ ((visibility ("hidden"))) guess_jp(const char *buf, int buflen)
- {
- int i;
- const char *rv = NULL;
-@@ -137,7 +137,7 @@
- return NULL;
- }
-
--const char *guess_tw(const char *buf, int buflen)
-+const char * __attribute__ ((visibility ("hidden"))) guess_tw(const char *buf, int buflen)
- {
- int i;
- const char *rv = NULL;
-@@ -192,7 +192,7 @@
- return NULL;
- }
-
--const char *guess_cn(const char *buf, int buflen)
-+const char * __attribute__ ((visibility ("hidden"))) guess_cn(const char *buf, int buflen)
- {
- int i;
- const char *rv = NULL;
-@@ -250,7 +250,7 @@
- return NULL;
- }
-
--const char *guess_kr(const char *buf, int buflen)
-+const char * __attribute__ ((visibility ("hidden"))) guess_kr(const char *buf, int buflen)
- {
- int i;
- const char *rv = NULL;
-@@ -308,7 +308,7 @@
- return NULL;
- }
-
--const char *guess_ar(const char *buf, int buflen)
-+const char * __attribute__ ((visibility ("hidden"))) guess_ar(const char *buf, int buflen)
- {
- int i;
- const char *rv = NULL;
-@@ -357,7 +357,7 @@
- return NULL;
- }
-
--const char *guess_gr(const char *buf, int buflen)
-+const char * __attribute__ ((visibility ("hidden"))) guess_gr(const char *buf, int buflen)
- {
- int i;
- const char *rv = NULL;
-@@ -406,7 +406,7 @@
- return NULL;
- }
-
--const char *guess_ru(const char *buf, int buflen)
-+const char * __attribute__ ((visibility ("hidden"))) guess_ru(const char *buf, int buflen)
- {
- int i;
- const char *rv = NULL;
-@@ -459,7 +459,7 @@
- return NULL;
- }
-
--const char *guess_hw(const char *buf, int buflen)
-+const char * __attribute__ ((visibility ("hidden"))) guess_hw(const char *buf, int buflen)
- {
- int i;
- const char *rv = NULL;
-@@ -508,7 +508,7 @@
- return NULL;
- }
-
--const char *guess_pl(const char *buf, int buflen)
-+const char * __attribute__ ((visibility ("hidden"))) guess_pl(const char *buf, int buflen)
- {
- int i;
- const char *rv = NULL;
-@@ -557,7 +557,7 @@
- return NULL;
- }
-
--const char *guess_tr(const char *buf, int buflen)
-+const char * __attribute__ ((visibility ("hidden"))) guess_tr(const char *buf, int buflen)
- {
- int i;
- const char *rv = NULL;
-@@ -606,7 +606,7 @@
- return NULL;
- }
-
--const char *guess_bl(const char *buf, int buflen)
-+const char * __attribute__ ((visibility ("hidden"))) guess_bl(const char *buf, int buflen)
- {
- int i;
- const char *rv = NULL;
+ #endif
+