summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2022-11-13 22:43:26 +0000
committerColin Watson <cjwatson@debian.org>2022-11-13 22:43:26 +0000
commit550e4d95aa9b7ea6d28d737a778ebdffab22782e (patch)
tree47840736868dbeb9a17404912c8ba65598e77cc5
parent8254cb1791e1c1367e2e8855a6971c637899f5d6 (diff)
parent43cb79eaa81bb0e07a95418fd92eb0e9fb1bd7e6 (diff)
New upstream release (1.5.7)
-rw-r--r--ChangeLog85
-rw-r--r--NEWS.md8
-rw-r--r--README.md9
-rw-r--r--aclocal.m480
-rwxr-xr-xbuild-aux/ltmain.sh10
-rwxr-xr-xconfigure36
-rw-r--r--configure.ac2
-rw-r--r--debian/.git-dpm16
-rw-r--r--debian/changelog6
-rw-r--r--gl/m4/ltversion.m410
-rw-r--r--lib/Makefile.am2
-rw-r--r--lib/Makefile.in2
-rw-r--r--lib/libpipeline.pc.in2
-rw-r--r--m4/pipeline-socketpair.m46
-rw-r--r--man/libpipeline.335
15 files changed, 254 insertions, 55 deletions
diff --git a/ChangeLog b/ChangeLog
index c111701..03c47e9 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,88 @@
+2022-11-13 Colin Watson <cjwatson@debian.org>
+
+ Version: 1.5.7
+
+ * lib/Makefile.am (libpipeline_la_LDFLAGS): Bump -version-info to 6:7:5.
+
+2022-11-13 Colin Watson <cjwatson@debian.org>
+
+ Make socketpair configure tests compatible with C23
+
+ K&R-style zero-argument function definitions will no longer be
+ permitted.
+
+ * m4/pipeline-socketpair.m4 (PIPELINE_SOCKETPAIR_PIPE,
+ PIPELINE_SOCKETPAIR_MODE): Use `int main(void)`, not `int main()`.
+ * NEWS.md: Document this.
+
+2022-08-12 Colin Watson <cjwatson@debian.org>
+
+ Update pre-commit hooks
+
+ * .pre-commit-config.yaml (pre-commit-hooks): Update to v4.3.0.
+ (clang-format): Update to v14.0.6.
+
+2022-06-03 Colin Watson <cjwatson@debian.org>
+
+ Update manual page date
+
+ * man/libpipeline.3 (.Dd): Update to the date of the last substantial
+ modification. Leaving this as 2010 suggested more antiquity than we
+ need to suggest.
+
+2022-06-03 Colin Watson <cjwatson@debian.org>
+
+ Update home page URL
+
+ * README.md: Use `https://libpipeline.gitlab.io/libpipeline/`.
+ * lib/libpipeline.pc.in (URL): Likewise.
+
+2022-06-03 Colin Watson <cjwatson@debian.org>
+
+ web: Update last release
+
+ * web/index.html: Update to 1.5.6.
+
+2022-06-03 Colin Watson <cjwatson@debian.org>
+
+ web: Fix last-modified date generation
+
+ * .gitlab-ci.yml: Replace `@DATE@` with the current date in
+ `public/index.html`.
+ * web/index.html: Use `@DATE@` template.
+
+2022-06-03 Colin Watson <cjwatson@debian.org>
+
+ web: Assorted URL updates
+
+ * web/index.html: Update Git URLs to GitLab. Chase various redirects
+ and/or switch to HTTPS. Remove old Savannah link.
+
+2022-06-03 Colin Watson <cjwatson@debian.org>
+
+ Add GitLab Pages site
+
+ * .gitlab-ci.yml (stages): Add deploy.
+ (pages): New job.
+ * web/index.html, web/libpipeline-lightning-talk.odp, web/standard.css,
+ web/white.css: New files.
+
+2022-06-03 Colin Watson <cjwatson@debian.org>
+
+ Transferred Git repository to new group
+
+ * README.md: Change GitLab URL to
+ https://gitlab.com/libpipeline/libpipeline.
+ * NEWS.md: Document this.
+
+2022-04-28 Colin Watson <cjwatson@debian.org>
+
+ Add notes to libpipeline(3) of when functions were added
+
+ * man/libpipeline.3 (DESCRIPTION, ENVIRONMENT): Add various "Added in"
+ notes.
+ * NEWS.md: Document this.
+
2022-04-23 Colin Watson <cjwatson@debian.org>
Version: 1.5.6
diff --git a/NEWS.md b/NEWS.md
index 61fde31..ba8aaf8 100644
--- a/NEWS.md
+++ b/NEWS.md
@@ -1,3 +1,11 @@
+libpipeline 1.5.7 (13 November 2022)
+====================================
+
+ * Add notes to libpipeline(3) of when functions were added.
+ * Transferred Git repository to https://gitlab.com/libpipeline/libpipeline.
+ * Make `socketpair` tests used by `./configure --enable-socketpair-pipe`
+ compatible with C23.
+
libpipeline 1.5.6 (24 April 2022)
=================================
diff --git a/README.md b/README.md
index f84e222..a970033 100644
--- a/README.md
+++ b/README.md
@@ -1,6 +1,6 @@
# libpipeline, a pipeline manipulation library
-Git repository: https://gitlab.com/cjwatson/libpipeline
+Git repository: https://gitlab.com/libpipeline/libpipeline
libpipeline is a C library for setting up and running pipelines of
processes, without needing to involve shell command-line parsing which is
@@ -9,7 +9,8 @@ laboriously construct pipelines using lower-level primitives such as fork(2)
and execve(2).
Full programmers' documentation may be found using `man libpipeline`, and
-the [project homepage](https://nongnu.org/libpipeline/) has more background.
+the [project homepage](https://libpipeline.gitlab.io/libpipeline/) has more
+background.
## Installation
@@ -230,6 +231,6 @@ design review, and Kees Cook and Matthias Klose for helpful conversations.
## Bug reporting
You can [report bugs on
-GitLab](https://gitlab.com/cjwatson/libpipeline/-/issues), or see [bugs from
-before the migration to
+GitLab](https://gitlab.com/libpipeline/libpipeline/-/issues), or see [bugs
+from before the migration to
GitLab](https://savannah.nongnu.org/bugs/?group=libpipeline).
diff --git a/aclocal.m4 b/aclocal.m4
index 2e5afc4..45c118d 100644
--- a/aclocal.m4
+++ b/aclocal.m4
@@ -21,7 +21,7 @@ If you have problems, you may need to regenerate the build system entirely.
To do so, use the procedure documented by the package, typically 'autoreconf'.])])
# pkg.m4 - Macros to locate and utilise pkg-config. -*- Autoconf -*-
-# serial 12 (pkg-config-0.29.2)
+# serial 11 (pkg-config-0.29.1)
dnl Copyright © 2004 Scott James Remnant <scott@netsplit.com>.
dnl Copyright © 2012-2015 Dan Nicholson <dbn.lists@gmail.com>
@@ -63,7 +63,7 @@ dnl
dnl See the "Since" comment for each macro you use to see what version
dnl of the macros you require.
m4_defun([PKG_PREREQ],
-[m4_define([PKG_MACROS_VERSION], [0.29.2])
+[m4_define([PKG_MACROS_VERSION], [0.29.1])
m4_if(m4_version_compare(PKG_MACROS_VERSION, [$1]), -1,
[m4_fatal([pkg.m4 version $1 or higher is required but ]PKG_MACROS_VERSION[ found])])
])dnl PKG_PREREQ
@@ -164,7 +164,7 @@ AC_ARG_VAR([$1][_CFLAGS], [C compiler flags for $1, overriding pkg-config])dnl
AC_ARG_VAR([$1][_LIBS], [linker flags for $1, overriding pkg-config])dnl
pkg_failed=no
-AC_MSG_CHECKING([for $2])
+AC_MSG_CHECKING([for $1])
_PKG_CONFIG([$1][_CFLAGS], [cflags], [$2])
_PKG_CONFIG([$1][_LIBS], [libs], [$2])
@@ -174,11 +174,11 @@ and $1[]_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.])
if test $pkg_failed = yes; then
- AC_MSG_RESULT([no])
+ AC_MSG_RESULT([no])
_PKG_SHORT_ERRORS_SUPPORTED
if test $_pkg_short_errors_supported = yes; then
$1[]_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "$2" 2>&1`
- else
+ else
$1[]_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "$2" 2>&1`
fi
# Put the nasty error message in config.log where it belongs
@@ -195,7 +195,7 @@ installed software in a non-standard prefix.
_PKG_TEXT])[]dnl
])
elif test $pkg_failed = untried; then
- AC_MSG_RESULT([no])
+ AC_MSG_RESULT([no])
m4_default([$4], [AC_MSG_FAILURE(
[The pkg-config script could not be found or is too old. Make sure it
is in your PATH or set the PKG_CONFIG environment variable to the full
@@ -296,6 +296,74 @@ AS_VAR_COPY([$1], [pkg_cv_][$1])
AS_VAR_IF([$1], [""], [$5], [$4])dnl
])dnl PKG_CHECK_VAR
+dnl PKG_WITH_MODULES(VARIABLE-PREFIX, MODULES,
+dnl [ACTION-IF-FOUND],[ACTION-IF-NOT-FOUND],
+dnl [DESCRIPTION], [DEFAULT])
+dnl ------------------------------------------
+dnl
+dnl Prepare a "--with-" configure option using the lowercase
+dnl [VARIABLE-PREFIX] name, merging the behaviour of AC_ARG_WITH and
+dnl PKG_CHECK_MODULES in a single macro.
+AC_DEFUN([PKG_WITH_MODULES],
+[
+m4_pushdef([with_arg], m4_tolower([$1]))
+
+m4_pushdef([description],
+ [m4_default([$5], [build with ]with_arg[ support])])
+
+m4_pushdef([def_arg], [m4_default([$6], [auto])])
+m4_pushdef([def_action_if_found], [AS_TR_SH([with_]with_arg)=yes])
+m4_pushdef([def_action_if_not_found], [AS_TR_SH([with_]with_arg)=no])
+
+m4_case(def_arg,
+ [yes],[m4_pushdef([with_without], [--without-]with_arg)],
+ [m4_pushdef([with_without],[--with-]with_arg)])
+
+AC_ARG_WITH(with_arg,
+ AS_HELP_STRING(with_without, description[ @<:@default=]def_arg[@:>@]),,
+ [AS_TR_SH([with_]with_arg)=def_arg])
+
+AS_CASE([$AS_TR_SH([with_]with_arg)],
+ [yes],[PKG_CHECK_MODULES([$1],[$2],$3,$4)],
+ [auto],[PKG_CHECK_MODULES([$1],[$2],
+ [m4_n([def_action_if_found]) $3],
+ [m4_n([def_action_if_not_found]) $4])])
+
+m4_popdef([with_arg])
+m4_popdef([description])
+m4_popdef([def_arg])
+
+])dnl PKG_WITH_MODULES
+
+dnl PKG_HAVE_WITH_MODULES(VARIABLE-PREFIX, MODULES,
+dnl [DESCRIPTION], [DEFAULT])
+dnl -----------------------------------------------
+dnl
+dnl Convenience macro to trigger AM_CONDITIONAL after PKG_WITH_MODULES
+dnl check._[VARIABLE-PREFIX] is exported as make variable.
+AC_DEFUN([PKG_HAVE_WITH_MODULES],
+[
+PKG_WITH_MODULES([$1],[$2],,,[$3],[$4])
+
+AM_CONDITIONAL([HAVE_][$1],
+ [test "$AS_TR_SH([with_]m4_tolower([$1]))" = "yes"])
+])dnl PKG_HAVE_WITH_MODULES
+
+dnl PKG_HAVE_DEFINE_WITH_MODULES(VARIABLE-PREFIX, MODULES,
+dnl [DESCRIPTION], [DEFAULT])
+dnl ------------------------------------------------------
+dnl
+dnl Convenience macro to run AM_CONDITIONAL and AC_DEFINE after
+dnl PKG_WITH_MODULES check. HAVE_[VARIABLE-PREFIX] is exported as make
+dnl and preprocessor variable.
+AC_DEFUN([PKG_HAVE_DEFINE_WITH_MODULES],
+[
+PKG_HAVE_WITH_MODULES([$1],[$2],[$3],[$4])
+
+AS_IF([test "$AS_TR_SH([with_]m4_tolower([$1]))" = "yes"],
+ [AC_DEFINE([HAVE_][$1], 1, [Enable ]m4_tolower([$1])[ support])])
+])dnl PKG_HAVE_DEFINE_WITH_MODULES
+
# Copyright (C) 2002-2021 Free Software Foundation, Inc.
#
# This file is free software; the Free Software Foundation
diff --git a/build-aux/ltmain.sh b/build-aux/ltmain.sh
index 16be3d9..8fb8700 100755
--- a/build-aux/ltmain.sh
+++ b/build-aux/ltmain.sh
@@ -2,7 +2,7 @@
## DO NOT EDIT - This file generated from ./build-aux/ltmain.in
## by inline-source v2019-02-19.15
-# libtool (GNU libtool) 2.4.6
+# libtool (GNU libtool) 2.4.7
# Provide generalized library-building support services.
# Written by Gordon Matzigkeit <gord@gnu.ai.mit.edu>, 1996
@@ -31,8 +31,8 @@
PROGRAM=libtool
PACKAGE=libtool
-VERSION="2.4.6 Debian-2.4.7-3"
-package_revision=2.4.6
+VERSION="2.4.7 Debian-2.4.7-4"
+package_revision=2.4.7
## ------ ##
@@ -2217,7 +2217,7 @@ func_version ()
# End:
# Set a version string.
-scriptversion='(GNU libtool) 2.4.6'
+scriptversion='(GNU libtool) 2.4.7'
# func_echo ARG...
@@ -2308,7 +2308,7 @@ include the following information:
compiler: $LTCC
compiler flags: $LTCFLAGS
linker: $LD (gnu? $with_gnu_ld)
- version: $progname $scriptversion Debian-2.4.7-3
+ version: $progname $scriptversion Debian-2.4.7-4
automake: `($AUTOMAKE --version) 2>/dev/null |$SED 1q`
autoconf: `($AUTOCONF --version) 2>/dev/null |$SED 1q`
diff --git a/configure b/configure
index f983402..532a9bf 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.71 for libpipeline 1.5.6.
+# Generated by GNU Autoconf 2.71 for libpipeline 1.5.7.
#
# Report bugs to <cjwatson@debian.org>.
#
@@ -621,8 +621,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='libpipeline'
PACKAGE_TARNAME='libpipeline'
-PACKAGE_VERSION='1.5.6'
-PACKAGE_STRING='libpipeline 1.5.6'
+PACKAGE_VERSION='1.5.7'
+PACKAGE_STRING='libpipeline 1.5.7'
PACKAGE_BUGREPORT='cjwatson@debian.org'
PACKAGE_URL=''
@@ -2335,7 +2335,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures libpipeline 1.5.6 to adapt to many kinds of systems.
+\`configure' configures libpipeline 1.5.7 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -2406,7 +2406,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of libpipeline 1.5.6:";;
+ short | recursive ) echo "Configuration of libpipeline 1.5.7:";;
esac
cat <<\_ACEOF
@@ -2542,7 +2542,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-libpipeline configure 1.5.6
+libpipeline configure 1.5.7
generated by GNU Autoconf 2.71
Copyright (C) 2021 Free Software Foundation, Inc.
@@ -3204,7 +3204,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by libpipeline $as_me 1.5.6, which was
+It was created by libpipeline $as_me 1.5.7, which was
generated by GNU Autoconf 2.71. Invocation command line was
$ $0$ac_configure_args_raw
@@ -4506,7 +4506,7 @@ fi
# Define the identity of the package.
PACKAGE='libpipeline'
- VERSION='1.5.6'
+ VERSION='1.5.7'
printf "%s\n" "#define PACKAGE \"$PACKAGE\"" >>confdefs.h
@@ -9299,8 +9299,8 @@ esac
-macro_version='2.4.6'
-macro_revision='2.4.6'
+macro_version='2.4.7'
+macro_revision='2.4.7'
@@ -17353,8 +17353,8 @@ printf "%s\n" "no" >&6; }
fi
pkg_failed=no
-{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking for check >= 0.9.10" >&5
-printf %s "checking for check >= 0.9.10... " >&6; }
+{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking for CHECK" >&5
+printf %s "checking for CHECK... " >&6; }
if test -n "$CHECK_CFLAGS"; then
pkg_cv_CHECK_CFLAGS="$CHECK_CFLAGS"
@@ -17394,7 +17394,7 @@ fi
if test $pkg_failed = yes; then
- { printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: no" >&5
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: no" >&5
printf "%s\n" "no" >&6; }
if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
@@ -17412,7 +17412,7 @@ fi
run_tests=no
elif test $pkg_failed = untried; then
- { printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: no" >&5
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: no" >&5
printf "%s\n" "no" >&6; }
run_tests=no
else
@@ -33064,7 +33064,7 @@ static void sigpipe(int sig)
_exit(0);
}
-int main()
+int main(void)
{
const char test[] = "May use socketpair(2) instead of pipe(2)\n";
char buf[256];
@@ -33146,7 +33146,7 @@ else $as_nop
# define SHUT_WR 1
#endif
-int main()
+int main(void)
{
int sfd[2];
struct stat st[2];
@@ -33803,7 +33803,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by libpipeline $as_me 1.5.6, which was
+This file was extended by libpipeline $as_me 1.5.7, which was
generated by GNU Autoconf 2.71. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -33871,7 +33871,7 @@ ac_cs_config_escaped=`printf "%s\n" "$ac_cs_config" | sed "s/^ //; s/'/'\\\\\\\\
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config='$ac_cs_config_escaped'
ac_cs_version="\\
-libpipeline config.status 1.5.6
+libpipeline config.status 1.5.7
configured by $0, generated by GNU Autoconf 2.71,
with options \\"\$ac_cs_config\\"
diff --git a/configure.ac b/configure.ac
index 663ea44..b6e2f25 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,7 +22,7 @@ dnl Process this file with autoconf to produce a configure script.
m4_pattern_forbid([^PIPELINE_])
# Initialise and check we're in the correct directory.
-AC_INIT([libpipeline], [1.5.6], [cjwatson@debian.org])
+AC_INIT([libpipeline], [1.5.7], [cjwatson@debian.org])
AC_CONFIG_AUX_DIR([build-aux])
AM_INIT_AUTOMAKE([1.11 -Wall -Werror foreign])
AM_MAINTAINER_MODE
diff --git a/debian/.git-dpm b/debian/.git-dpm
index 797f57c..3afedd9 100644
--- a/debian/.git-dpm
+++ b/debian/.git-dpm
@@ -1,12 +1,12 @@
# see git-dpm(1) from git-dpm package
-9683147ec6cb1ca7af7e7664a3f108db1e1949cf
-9683147ec6cb1ca7af7e7664a3f108db1e1949cf
-9683147ec6cb1ca7af7e7664a3f108db1e1949cf
-9683147ec6cb1ca7af7e7664a3f108db1e1949cf
-libpipeline_1.5.6.orig.tar.gz
-2e0fa2fcc0b1aa3ea85077725f5b3a61d7a0ddf0
-976516
+43cb79eaa81bb0e07a95418fd92eb0e9fb1bd7e6
+43cb79eaa81bb0e07a95418fd92eb0e9fb1bd7e6
+43cb79eaa81bb0e07a95418fd92eb0e9fb1bd7e6
+43cb79eaa81bb0e07a95418fd92eb0e9fb1bd7e6
+libpipeline_1.5.7.orig.tar.gz
+9c39266d32d487b5288bdbe893c4b5a5b8577adb
+977735
debianTag="debian/%V"
patchedTag="patched/%V"
upstreamTag="upstream/%U"
-signature:ca840625b816ed495cbc5142980f018eaf6087ab:833:libpipeline_1.5.6.orig.tar.gz.asc
+signature:5e2a2c139f20e55e224c1a908bac088cd6bf864c:833:libpipeline_1.5.7.orig.tar.gz.asc
diff --git a/debian/changelog b/debian/changelog
index 579d3f6..81b4071 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+libpipeline (1.5.7-1) UNRELEASED; urgency=medium
+
+ * New upstream release.
+
+ -- Colin Watson <cjwatson@debian.org> Sun, 13 Nov 2022 22:42:35 +0000
+
libpipeline (1.5.6-3) unstable; urgency=medium
* Stop avoiding -fPIC when building tests, since check has provided a
diff --git a/gl/m4/ltversion.m4 b/gl/m4/ltversion.m4
index 64561ed..b155d0a 100644
--- a/gl/m4/ltversion.m4
+++ b/gl/m4/ltversion.m4
@@ -10,15 +10,15 @@
# @configure_input@
-# serial 4179 ltversion.m4
+# serial 4245 ltversion.m4
# This file is part of GNU Libtool
-m4_define([LT_PACKAGE_VERSION], [2.4.6])
-m4_define([LT_PACKAGE_REVISION], [2.4.6])
+m4_define([LT_PACKAGE_VERSION], [2.4.7])
+m4_define([LT_PACKAGE_REVISION], [2.4.7])
AC_DEFUN([LTVERSION_VERSION],
-[macro_version='2.4.6'
-macro_revision='2.4.6'
+[macro_version='2.4.7'
+macro_revision='2.4.7'
_LT_DECL(, macro_version, 0, [Which release of libtool.m4 was used?])
_LT_DECL(, macro_revision, 0)
])
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 5695392..844c4ef 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -42,7 +42,7 @@ libpipeline_la_LIBADD = ../gl/lib/libgnu.la $(LTLIBOBJS)
libpipeline_la_LDFLAGS = \
-export-symbols-regex '^(pipecmd|pipeline)_' \
-no-undefined \
- -version-info 6:6:5
+ -version-info 6:7:5
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libpipeline.pc
diff --git a/lib/Makefile.in b/lib/Makefile.in
index 6ba8034..03d7814 100644
--- a/lib/Makefile.in
+++ b/lib/Makefile.in
@@ -1299,7 +1299,7 @@ libpipeline_la_LIBADD = ../gl/lib/libgnu.la $(LTLIBOBJS)
libpipeline_la_LDFLAGS = \
-export-symbols-regex '^(pipecmd|pipeline)_' \
-no-undefined \
- -version-info 6:6:5
+ -version-info 6:7:5
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libpipeline.pc
diff --git a/lib/libpipeline.pc.in b/lib/libpipeline.pc.in
index cc8a428..592e272 100644
--- a/lib/libpipeline.pc.in
+++ b/lib/libpipeline.pc.in
@@ -25,6 +25,6 @@ includedir=@includedir@
Name: @PACKAGE_NAME@
Description: Pipeline manipulation library
Version: @PACKAGE_VERSION@
-URL: https://nongnu.org/libpipeline/
+URL: https://libpipeline.gitlab.io/libpipeline/
Libs: -L${libdir} -lpipeline
Cflags: -I${includedir}
diff --git a/m4/pipeline-socketpair.m4 b/m4/pipeline-socketpair.m4
index d62b568..9b6d834 100644
--- a/m4/pipeline-socketpair.m4
+++ b/m4/pipeline-socketpair.m4
@@ -1,4 +1,4 @@
-# pipeline-socketpair.m4 serial 2
+# pipeline-socketpair.m4 serial 3
dnl
dnl Check if the socketpair(2) system call can be used
dnl and should be used as a fast replacement for pipe(2)
@@ -28,7 +28,7 @@ static void sigpipe(int sig)
_exit(0);
}
-int main()
+int main(void)
{
const char test[] = "May use socketpair(2) instead of pipe(2)\n";
char buf[256];
@@ -88,7 +88,7 @@ AC_DEFUN([PIPELINE_SOCKETPAIR_MODE],
# define SHUT_WR 1
#endif
-int main()
+int main(void)
{
int sfd[2];
struct stat st[2];
diff --git a/man/libpipeline.3 b/man/libpipeline.3
index cf19907..347414b 100644
--- a/man/libpipeline.3
+++ b/man/libpipeline.3
@@ -1,4 +1,4 @@
-.\" Copyright (C) 2010-2017 Colin Watson.
+.\" Copyright (C) 2010-2022 Colin Watson.
.\"
.\" This file is part of libpipeline.
.\"
@@ -16,7 +16,7 @@
.\" along with libpipeline; if not, write to the Free Software
.\" Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301
.\" USA.
-.Dd October 11, 2010
+.Dd April 28, 2022
.Os GNU
.ds volume-operating-system GNU
.Dt LIBPIPELINE 3
@@ -186,6 +186,10 @@ command
.Sq echo foo bar
is counted as having three arguments.
.Pp
+Added in
+.Nm
+1.1.0.
+.Pp
.It Ft void Fn pipecmd_nice "pipecmd *cmd" "int value"
.Pp
Set the
@@ -210,6 +214,10 @@ Change the working directory to
.Va directory
while running this command.
.Pp
+Added in
+.Nm
+1.3.0.
+.Pp
.It Ft void Fn pipecmd_fchdir "pipecmd *cmd" "int directory_fd"
.Pp
Change the working directory to the directory given by the open file
@@ -217,6 +225,10 @@ descriptor
.Va directory_fd
while running this command.
.Pp
+Added in
+.Nm
+1.4.0.
+.Pp
.It Xo Ft void
.Fn pipecmd_setenv "pipecmd *cmd" "const char *name" "const char *value"
.Xc
@@ -243,6 +255,10 @@ Beware that this may cause unexpected failures, for example if some of the
contents of the environment are necessary to execute programs at all (say,
.Li PATH ) .
.Pp
+Added in
+.Nm
+1.1.0.
+.Pp
.It Xo Ft void
.Fo pipecmd_pre_exec
.Fa "pipecmd *cmd"
@@ -263,6 +279,10 @@ This is similar to pipeline_install_post_fork, except that is specific to a
single command rather than installing a global handler, and it runs slightly
later (immediately before exec rather than immediately after fork).
.Pp
+Added in
+.Nm
+1.5.0.
+.Pp
.It Ft void Fn pipecmd_sequence_command "pipecmd *cmd" "pipecmd *child"
.Pp
Add a command to a sequence created using
@@ -282,6 +302,10 @@ The caller should free the result.
Execute a single command, replacing the current process.
Never returns, instead exiting non-zero on failure.
.Pp
+Added in
+.Nm
+1.1.0.
+.Pp
.It Ft void Fn pipecmd_free "pipecmd *cmd"
.Pp
Destroy a command.
@@ -490,6 +514,10 @@ if
.Va n
is out of range or if the command has already exited and been reaped.
.Pp
+Added in
+.Nm
+1.2.0.
+.Pp
.It Ft "FILE *" Ns Fn pipeline_get_infile "pipeline *p"
.It Ft "FILE *" Ns Fn pipeline_get_outfile "pipeline *p"
.Pp
@@ -721,6 +749,9 @@ environment variable is set to any value, then
.Nm
will refrain from printing an error message when a subprocess is terminated
by a signal.
+Added in
+.Nm
+1.4.0.
.Sh EXAMPLES
In the following examples, function names starting with
.Li pipecmd_