summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2012-05-23 11:26:25 +0200
committerDidier Raboud <odyx@debian.org>2012-05-23 14:56:48 +0200
commitdc879c4d190efdd6511fd9c8d0b3f291751a2a9c (patch)
tree53e284a37f8abd85098be0eb790587d3f41c286e /test
parent875a74945759e94fcbac2a7cb718f5008b2a0fe4 (diff)
PyUT3: Fix rnd_string to use ascii_letters and range instead of letters and xrange.
Git-Dch: None
Diffstat (limited to 'test')
-rw-r--r--test/test_lsb_release.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/test_lsb_release.py b/test/test_lsb_release.py
index 87e5af0..7e85769 100644
--- a/test/test_lsb_release.py
+++ b/test/test_lsb_release.py
@@ -9,7 +9,7 @@ import string
import os
def rnd_string(min_l,max_l):
- return ''.join( [random.choice(string.letters) for i in xrange(random.randint(min_l,max_l))])
+ return ''.join( [random.choice(string.ascii_letters) for i in range(random.randint(min_l,max_l))])
def get_arch_distinfo():
# Copied verbatim from guess_debian_release; sucks but unavoidable.