summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJohn Wright <jsw@debian.org>2009-11-12 20:21:23 -0700
committerJohn Wright <jsw@debian.org>2010-03-03 13:47:27 -0700
commitd519a985494f147a36ddf7e665ec406c26f41197 (patch)
tree81066e8eea2c98b30e8b29f5b8a0e2d4b817e277 /debian/rules
parentf1ed3c7f3f20dcc4810606af98bee646c19455c2 (diff)
Preserve upstream's original makedumpfile.8
The Makefile modifies makedumpfile.8 in place. If the .orig.tar.gz had the already-updated version, this bug wouldn't manifest itself, but in version 1.3.4, makedumpfile.8 had a header from version 1.3.3. So, if we built the package, then ran "debian/rules clean", we wound up with different source than we started with. So, we now make a copy of makedumpfile.8 before dh_auto_build, and copy the original back before dh_auto_clean.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index e039753..887f5c5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,6 +17,19 @@ override_dh_installinit:
# all the way until actual shutdown.
dh_installinit -pkdump-tools -- start 11 2 3 4 5 .
+# The upstream Makefile modifies makedumpfile.8 in place, so without this hack
+# (or a patch to the Makefile, which would be harder to maintain), our clean
+# target won't get us back to the original source.
+override_dh_auto_build:
+ cp makedumpfile.8 makedumpfile.8.orig
+ dh_auto_build
+
+override_dh_auto_clean:
+ if [ -f makedumpfile.8.orig ]; then \
+ mv makedumpfile.8.orig makedumpfile.8; \
+ fi
+ dh_auto_clean
+
guilt-patches:
dh_testdir
dh_quilt_unpatch