summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2019-01-29 12:20:23 +0000
committerColin Watson <cjwatson@debian.org>2019-01-29 12:21:10 +0000
commit056e8c7c012b00261133259d6438ff8303a8c36c (patch)
tree0de300f52c602133a62ad5106b8d637e2e0e14d9 /configure.ac
parent7b19a3463542ec989df9eb10af455b28476f0b6f (diff)
Fix failure to link libman using the Darwin linker
Thanks to George Plymale II and John Gardner. * configure.ac: Add "-Wl,-flat_namespace,-undefined,suppress" to CFLAGS on Darwin. * NEWS: Document this.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5d761d5e..e4abb173 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,6 +59,13 @@ case $host_os in
dnl environment:
CFLAGS="$CFLAGS -YPOSIX"
;;
+ *darwin*)
+ dnl libman intentionally has an undefined "sandbox" symbol
+ dnl which is supplied by each application. The Darwin
+ dnl linker refuses to do this by default, and needs some
+ dnl help.
+ CFLAGS="$CFLAGS -Wl,-flat_namespace,-undefined,suppress"
+ ;;
esac
if test "$GCC" = yes
then