summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5d761d5e..e4abb173 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,6 +59,13 @@ case $host_os in
dnl environment:
CFLAGS="$CFLAGS -YPOSIX"
;;
+ *darwin*)
+ dnl libman intentionally has an undefined "sandbox" symbol
+ dnl which is supplied by each application. The Darwin
+ dnl linker refuses to do this by default, and needs some
+ dnl help.
+ CFLAGS="$CFLAGS -Wl,-flat_namespace,-undefined,suppress"
+ ;;
esac
if test "$GCC" = yes
then