summaryrefslogtreecommitdiff
path: root/src/mozclient.pl
diff options
context:
space:
mode:
authorFabien Tassin <fta@sofaraway.org>2008-06-06 16:43:57 +0200
committerFabien Tassin <fta@sofaraway.org>2008-06-06 16:43:57 +0200
commitbe5a1ab14a35ce8d409d56041eb54f63dec4972a (patch)
tree08bfb479473600e23164df300f88d459ae39dd60 /src/mozclient.pl
parentaef58670311206d471f316d7fe7e161c67332d04 (diff)
* [mozclient] use an absolute path for remove.binonly.sh as with --conf-dir it could
be called from anywhere. Move remove.binonly.sh into mozclient/ - move src/remove.binonly.sh => src/mozclient/remove.binonly.sh - update src/Makefile - update src/mozclient.pl - update src/mozclient/lib/MozClient/VCS.pm
Diffstat (limited to 'src/mozclient.pl')
-rwxr-xr-xsrc/mozclient.pl5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/mozclient.pl b/src/mozclient.pl
index 591ba86..30a9722 100755
--- a/src/mozclient.pl
+++ b/src/mozclient.pl
@@ -22,6 +22,7 @@
use strict;
use Getopt::Long qw(:config no_auto_abbrev no_ignore_case
require_order bundling);
+use Cwd 'abs_path';
BEGIN {
my $conf_dir = "/usr/share/mozilla-devscripts/mozclient";
@@ -42,7 +43,7 @@ BEGIN {
}
$INC[0] =~ m,(.*)/lib$,;
-my $mozclient_dir = $1;
+my $mozclient_dir = abs_path($1);
my $pkg_conf_dir = "$mozclient_dir";
my $patches_dir = "$pkg_conf_dir/patches";
my $work_dir = "mozclient-tmp";
@@ -57,7 +58,7 @@ my @conf_list = qw(MOZCLIENT_FILE);
my $defaults = {
'MOZCLIENT_SEPARATOR' => '~',
- 'MOZCLIENT_EXCLUDE_SCRIPT' => 'remove.binonly.sh',
+ 'MOZCLIENT_EXCLUDE_SCRIPT' => "$pkg_conf_dir/remove.binonly.sh",
'MOZILLA_CLIENT' => 'mozilla/client.mk',
'MOZCLIENT_PATCHES' => "$patches_dir",
};