summaryrefslogtreecommitdiff
path: root/src/mozclient
diff options
context:
space:
mode:
authorFabien Tassin <fta@sofaraway.org>2008-06-18 00:42:35 +0200
committerFabien Tassin <fta@sofaraway.org>2008-06-18 00:42:35 +0200
commitd708fadc6aa0424b3f4a48844ff983074bea937a (patch)
treef3b89618c9534a1e5a46a9e9cf7b9a87e37b925e /src/mozclient
parentb646a27d277860bd3d61517f136f46c0e861f42f (diff)
* [mozclient] add --embedded|-e for embedded tarballs. This is controlled
by the MOZCLIENT_EMBEDDED variable from the Makefile - update src/mozclient/lib/MozClient/VCS.pm - update src/mozclient/mozclient.pl - update src/mozclient.mk.in
Diffstat (limited to 'src/mozclient')
-rw-r--r--src/mozclient/lib/MozClient/VCS.pm3
-rwxr-xr-xsrc/mozclient/mozclient.pl2
2 files changed, 5 insertions, 0 deletions
diff --git a/src/mozclient/lib/MozClient/VCS.pm b/src/mozclient/lib/MozClient/VCS.pm
index d97e45c..d2dd318 100644
--- a/src/mozclient/lib/MozClient/VCS.pm
+++ b/src/mozclient/lib/MozClient/VCS.pm
@@ -59,6 +59,9 @@ sub new {
$self->{'want_branch'} = $$conf{'MOZCLIENT_BRANCH'}
if defined $$conf{'MOZCLIENT_BRANCH'} && !defined $self->{'want_branch'};
+ # The following options overwrite the conf files
+ $self->{'MOZCLIENT_EMBEDDED'} = 1 if $$opt{'embedded'};
+
bless($self, $class);
$self;
}
diff --git a/src/mozclient/mozclient.pl b/src/mozclient/mozclient.pl
index c6ee8b7..5c8d995 100755
--- a/src/mozclient/mozclient.pl
+++ b/src/mozclient/mozclient.pl
@@ -75,6 +75,7 @@ mozclient [-l] project-name
--tag|-t tag checkout using a tag
--tag|-t tag=ver checkout using a tag, hard-coding the version
--preserve-vcs|-p preserve VCS files
+ --embedded|-e create an embedded tarball
--debug|-D increase debug level
Examples:
@@ -181,6 +182,7 @@ GetOptions($opt,
'branch|b=s',
'date|d=s',
'tag|t=s',
+ 'embedded|e',
'preserve-vcs|p') || &help();
&help() unless $#ARGV >= 0;