summaryrefslogtreecommitdiff
path: root/src/xpi.mk
diff options
context:
space:
mode:
authorAlexander Sack <asac@ubuntu.com>2009-07-27 00:21:39 +0200
committerAlexander Sack <asac@ubuntu.com>2009-07-27 00:21:39 +0200
commit817fc00f5757a79240b317058597b75fd130fd33 (patch)
tree954c5a6ec06dbebdf986c0982d07574cca34ce88 /src/xpi.mk
parent97091078eb24826a9a82ebc2b72b3f7471e43828 (diff)
* move add stamp-unzip-$(XPI_BASE_FILE) to stamp-extension-install: and
remove it from stamp-installlinks-% - which was the wrong place anyway - update src/xpi.mk
Diffstat (limited to 'src/xpi.mk')
-rw-r--r--src/xpi.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/xpi.mk b/src/xpi.mk
index 673cf83..3dad571 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -107,7 +107,7 @@ stamp-unzip-%: $(XPI_FILE)
unzip -d $(TEMPDIR) $(XPI_DIR)$*
touch $@
-stamp-installlinks-%: stamp-unzip-%*
+stamp-installlinks-%:
dh_link -p$(MOZ_EXTENSION_PKG) /usr/share/$(MOZ_EXTENSION_PKG) /usr/lib/$*/extensions/$(call XPI_EMID,$(TEMPDIR))
touch $@
@@ -118,7 +118,7 @@ stamp-install-%: stamp-autolinks
dh_install -p$(MOZ_EXTENSION_PKG) $(wildcard $(TEMPDIR)/*) /usr/share/$(MOZ_EXTENSION_PKG)
touch $@
-stamp-extension-install: stamp-install-$(XPI_BASE_FILE)
+stamp-extension-install: stamp-unzip-$(XPI_BASE_FILE) stamp-install-$(XPI_BASE_FILE)
touch $@